summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortoluschr2019-03-14 18:14:27 +0100
committertoluschr2019-03-14 18:14:27 +0100
commit0637a275e4b049af2e223e11deae13fa3389411f (patch)
treef562dbc9030b2be9be3c3bc34d71497588c15479
downloadaur-0637a275e4b049af2e223e11deae13fa3389411f.tar.gz
Added: Desktop entry and working install script
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD38
-rw-r--r--ms-office-online-nativefier.desktop8
-rw-r--r--ms-office-online-nativefier.pngbin0 -> 9310 bytes
4 files changed, 63 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..154266961145
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = ms-office-online-nativefier
+ pkgdesc = Microsoft Office Online is an Office suite that is offered as a free web application and is part of the Microsoft Office family.
+ pkgver = 0.1
+ pkgrel = 1
+ url = https://github.com/jiahaog/nativefier
+ arch = x86_64
+ license = MIT
+ makedepends = nodejs
+ makedepends = npm
+ makedepends = nodejs-nativefier
+ source = ms-office-online-nativefier.png
+ source = ms-office-online-nativefier.desktop
+ sha256sums = SKIP
+ sha256sums = SKIP
+
+pkgname = ms-office-online-nativefier
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f1a4ffbbedd4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Murat Çileli <murat.cileli@gmail.com>
+
+pkgname="ms-office-online-nativefier"
+pkgver="0.1"
+pkgrel="1"
+pkgdesc="Microsoft Office Online is an Office suite that is offered as a free web application and is part of the Microsoft Office family."
+arch=("x86_64")
+license=("MIT")
+url="https://github.com/jiahaog/nativefier"
+source=("${pkgname}.png" "${pkgname}.desktop")
+makedepends=("nodejs" "npm" "nodejs-nativefier")
+sha256sums=("SKIP" "SKIP")
+
+build() {
+ cd "${srcdir}"
+
+ nativefier "https://www.office.com" \
+ --icon "${pkgname}.png" \
+ --maximize \
+ --internal-urls ".*" \
+ --name "Microsoft Office Online"
+}
+
+package() {
+ install -dm755 "${pkgdir}/opt/"
+ install -dm755 "${pkgdir}/usr/bin"
+ install -dm755 "${pkgdir}/usr/share/pixmaps"
+ install -dm755 "${pkgdir}/usr/share/applications"
+
+ cp -rf "${srcdir}/${pkgname}.desktop" "${pkgdir}/usr/share/applications/microsoft-office-online.desktop"
+ cp -rf "${srcdir}/microsoft-office-online-linux-x64" "${pkgdir}/opt/"
+
+ ln -sf "/opt/microsoft-office-online-linux-x64/microsoft-office-online" "${pkgdir}/usr/bin/microsoft-office-online"
+ ln -sf "/opt/microsoft-office-online-linux-x64/resources/app/icon.png" "${pkgdir}/usr/share/pixmaps/microsoft-office-online.png"
+
+ chmod 777 "${pkgdir}/opt/microsoft-office-online-linux-x64/resources/app/nativefier.json"
+}
+
diff --git a/ms-office-online-nativefier.desktop b/ms-office-online-nativefier.desktop
new file mode 100644
index 000000000000..4411e6e53d63
--- /dev/null
+++ b/ms-office-online-nativefier.desktop
@@ -0,0 +1,8 @@
+[Desktop Entry]
+Type=Application
+Name=Microsoft Office Online
+Comment=Microsoft Office Online is an Office suite that is offered as a free web application and is part of the Microsoft Office family.
+Exec=microsoft-office-online
+Icon=microsoft-office-online
+Terminal=false
+Categories=Office; \ No newline at end of file
diff --git a/ms-office-online-nativefier.png b/ms-office-online-nativefier.png
new file mode 100644
index 000000000000..eb3c19677878
--- /dev/null
+++ b/ms-office-online-nativefier.png
Binary files differ