summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChloe Colman2023-08-16 15:52:19 -0400
committerChloe Colman2023-08-16 15:52:19 -0400
commit0644fa0a7bb1287102a8d9dadd61f56c2b51b90f (patch)
treefcffc24fa2a60fb0a0bf1bb4d958ecb902d6f506
parent5077c328ac16d9340e11684516105136ec5b5786 (diff)
downloadaur-0644fa0a7bb1287102a8d9dadd61f56c2b51b90f.tar.gz
update to v8.2.0
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD17
2 files changed, 13 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0b66b5d00cad..685ca94e8d24 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = heroku-cli-bin
pkgdesc = CLI to Manage Heroku apps with forced auto-update removed. Packaged before release to save time and bandwidth.
- pkgver = 7.62.0
+ pkgver = 8.2.0
pkgrel = 1
url = https://devcenter.heroku.com/articles/heroku-cli
arch = any
@@ -15,8 +15,8 @@ pkgbase = heroku-cli-bin
conflicts = heroku-toolbelt
conflicts = ruby-heroku
options = !strip
- source = https://github.com/SampsonCrowley/heroku-cli-bin/raw/bc586f2b13674ff8cb1c283530b1f597fcc24826/heroku-cli-bin-v7.62.0-1.tar.xz
- sha256sums = a5af6edf75c5bdcf809cecee36ea1e91fd6df4db96cdf2d4cba318e4c037c526
- sha512sums = e9090f8982a8ea2cbcd56d712b6dbe698895a5881834842f13f26aa2d5f8b79b1f4562392922449cb8d4fa48eabea37961112426689458f609db2e45da5027c0
+ source = https://github.com/ChloeColman/heroku-cli-bin/raw/5530a9a217340187d93d89bc09a44514cf520769/heroku-cli-bin-v8.2.0-1.tar.xz
+ sha256sums = 622105d9ffc019624254295f9e85509efad7ef55c9e88eaed46c1b77560131f0
+ sha512sums = 51a2d41cc801c81dbde292fb51f4bd3a60c9b1ab3a0bdbd26b0b711fd644bc9bbd1d9e8cd43f843c07be4d57db4841f7e6efd8bf64ca0aaad25458c73c0cf0db
pkgname = heroku-cli-bin
diff --git a/PKGBUILD b/PKGBUILD
index 6e4131400ab7..95132486d2bd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,10 +1,11 @@
-# Maintainer: Sampson Crowley <sampsonsprojects@gmail.com>
+# Maintainer: Chloe Colman <chloe.colman7@gmail.com>
+# Contributor: Sampson Crowley <sampsonsprojects@gmail.com>
# Github Contributor: ahmubashir <https://github.com/amubashir>
pkgname=heroku-cli-bin
-pkgver=7.62.0
+pkgver=8.2.0
pkgrel=1
-_commit_id="bc586f2b13674ff8cb1c283530b1f597fcc24826"
+_commit_id="5530a9a217340187d93d89bc09a44514cf520769"
_builddir="cli-$pkgver-$pkgrel"
pkgdesc="CLI to Manage Heroku apps with forced auto-update removed. Packaged before release to save time and bandwidth."
arch=('any')
@@ -13,21 +14,21 @@ license=('custom' 'ISC')
depends=('nodejs')
optdepends=('git: Deploying to Heroku')
conflicts=('heroku-cli' 'heroku-client-standalone' 'heroku-toolbelt' 'ruby-heroku')
-source=("https://github.com/SampsonCrowley/heroku-cli-bin/raw/${_commit_id}/heroku-cli-bin-v$pkgver-$pkgrel.tar.xz")
-sha256sums=('a5af6edf75c5bdcf809cecee36ea1e91fd6df4db96cdf2d4cba318e4c037c526')
-sha512sums=('e9090f8982a8ea2cbcd56d712b6dbe698895a5881834842f13f26aa2d5f8b79b1f4562392922449cb8d4fa48eabea37961112426689458f609db2e45da5027c0')
+source=("https://github.com/ChloeColman/heroku-cli-bin/raw/${_commit_id}/heroku-cli-bin-v$pkgver-$pkgrel.tar.xz")
+sha256sums=('622105d9ffc019624254295f9e85509efad7ef55c9e88eaed46c1b77560131f0')
+sha512sums=('51a2d41cc801c81dbde292fb51f4bd3a60c9b1ab3a0bdbd26b0b711fd644bc9bbd1d9e8cd43f843c07be4d57db4841f7e6efd8bf64ca0aaad25458c73c0cf0db')
options=('!strip')
provides=('heroku' 'heroku-cli')
package() {
install -dm755 "$pkgdir/usr/lib/heroku"
- install -dm755 "$pkgdir/usr/bin"
+ install -dm755 "$pkgdir/usr/bin"
install -dm755 "$pkgdir/usr/share/licenses/$pkgname"
cp -a "$srcdir/heroku" "$pkgdir/usr/lib"
# completions
- local autocompletedir="$srcdir/heroku/node_modules/@heroku-cli/plugin-autocomplete/autocomplete"
+ local autocompletedir="$srcdir/heroku/autocomplete-scripts"
install -Dm644 "$autocompletedir/bash/heroku.bash" "$pkgdir/usr/share/bash-completion/completions/heroku"
install -Dm644 "$autocompletedir/zsh/_heroku" "$pkgdir/usr/share/zsh/site-functions/_heroku"