summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Doege2015-06-09 11:43:18 +0200
committerMartin Doege2015-06-09 11:43:18 +0200
commit066ef8aa1fb5a1a4514fd893f7be9d71f2a4bd12 (patch)
tree82fc7cf2c8fc1eb8ee6184aea9f885d70c32bdde
downloadaur-066ef8aa1fb5a1a4514fd893f7be9d71f2a4bd12.tar.gz
Initial import
-rw-r--r--.AURINFO16
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD30
-rw-r--r--SoundHelix-logo-medium.pngbin0 -> 21349 bytes
-rwxr-xr-xsoundhelix4
-rwxr-xr-xsoundhelix.desktop19
6 files changed, 89 insertions, 0 deletions
diff --git a/.AURINFO b/.AURINFO
new file mode 100644
index 000000000000..982b14fef3da
--- /dev/null
+++ b/.AURINFO
@@ -0,0 +1,16 @@
+pkgbase = soundhelix
+ pkgdesc = Tool for creating algorithmic random MIDI music
+ pkgver = 0.7.1
+ pkgrel = 1
+ url = http://www.soundhelix.com/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = java-runtime
+ source = http://downloads.sourceforge.net/project/soundhelix/SoundHelix-0.7.1-bin.zip
+ source = soundhelix
+ source = SoundHelix-logo-medium.png
+ source = soundhelix.desktop
+
+pkgname = soundhelix
+
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..609a5f5b0de0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = soundhelix
+ pkgdesc = Tool for creating algorithmic random MIDI music
+ pkgver = 0.7.1
+ pkgrel = 1
+ url = http://www.soundhelix.com/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = java-runtime
+ source = http://downloads.sourceforge.net/project/soundhelix/SoundHelix-0.7.1-bin.zip
+ source = soundhelix
+ source = SoundHelix-logo-medium.png
+ source = soundhelix.desktop
+ md5sums = 80bd37265f951346fbf9e4bbfbad8601
+ md5sums = 790b82587ddf5c6aab42589fc410250c
+ md5sums = eb639d466cb81d1e4ab34fc425538c50
+ md5sums = 688d5fce1d2304eb476bb6ee5ca591aa
+
+pkgname = soundhelix
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..be4e628fd60b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Martin C. Doege <mdoege at compuserve dot com>
+
+pkgname=soundhelix
+pkgver=0.7.1
+pkgrel=1
+pkgdesc="Tool for creating algorithmic random MIDI music"
+arch=('i686' 'x86_64')
+url="http://www.soundhelix.com/"
+license=('GPL')
+depends=('java-runtime')
+source=("http://downloads.sourceforge.net/project/soundhelix/SoundHelix-"$pkgver"-bin.zip"
+ "soundhelix"
+ "SoundHelix-logo-medium.png"
+ "soundhelix.desktop"
+ )
+md5sums=('80bd37265f951346fbf9e4bbfbad8601'
+ '790b82587ddf5c6aab42589fc410250c'
+ 'eb639d466cb81d1e4ab34fc425538c50'
+ '688d5fce1d2304eb476bb6ee5ca591aa')
+
+package() {
+ cd $srcdir/$pkgname-$pkgver
+ mkdir -p $pkgdir/usr/lib/soundhelix
+ cp -pr * $pkgdir/usr/lib/soundhelix
+
+ cd $srcdir
+ install -Dm 755 soundhelix $pkgdir/usr/bin/soundhelix
+ install -D SoundHelix-logo-medium.png $pkgdir/usr/share/icons/SoundHelix-logo-medium.png
+ install -D soundhelix.desktop $pkgdir/usr/share/applications/soundhelix.desktop
+}
diff --git a/SoundHelix-logo-medium.png b/SoundHelix-logo-medium.png
new file mode 100644
index 000000000000..818aa68636c5
--- /dev/null
+++ b/SoundHelix-logo-medium.png
Binary files differ
diff --git a/soundhelix b/soundhelix
new file mode 100755
index 000000000000..3068c328d023
--- /dev/null
+++ b/soundhelix
@@ -0,0 +1,4 @@
+#!/usr/bin/bash
+
+cd /usr/lib/soundhelix
+bash run.sh "$@"
diff --git a/soundhelix.desktop b/soundhelix.desktop
new file mode 100755
index 000000000000..856932357812
--- /dev/null
+++ b/soundhelix.desktop
@@ -0,0 +1,19 @@
+[Desktop Entry]
+Comment=
+Encoding=UTF-8
+Exec=soundhelix
+GenericName=Algorithmic music generator
+Icon=SoundHelix-logo-medium.png
+MimeType=
+Name=SoundHelix
+Path=
+StartupNotify=true
+Terminal=true
+TerminalOptions=
+Type=Application
+Version=1.0
+X-DBUS-ServiceName=
+X-DBUS-StartupType=
+X-KDE-SubstituteUID=false
+X-KDE-Username=
+Categories=Application;Music;Sound