summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorultraviolet2015-07-03 21:55:16 -0600
committerultraviolet2015-07-03 21:55:16 -0600
commit066f67737d49c0adbc819bed44ea5074ba865596 (patch)
tree9f5e68d5ef8a51d49eba322effbccdea37cf3d71
downloadaur-066f67737d49c0adbc819bed44ea5074ba865596.tar.gz
Initial import
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD21
2 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..46507a3d6fb3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = keepass-plugin-http
+ pkgdesc = KeePass plugin to expose password entries securely (256bit AES/CBC) over HTTP
+ pkgver = 1.8.4.0
+ pkgrel = 1
+ url = http://github.com/pfn/keepasshttp
+ arch = i686
+ arch = x86_64
+ license = unknown
+ depends = keepass
+ provides = keepasshttp
+ conflicts = keepasshttp
+ source = https://github.com/pfn/keepasshttp/raw/63fa55850fc4908527c453ff97765f5e945e389c/KeePassHttp.plgx
+ sha256sums = 4803ea799962ec3e294691922d6255e63c5a96df36941f99ef633775829e7289
+
+pkgname = keepass-plugin-http
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..41407da6eeca
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Contributor: Philipp 'TamCore' B. <philipp [at] tamcore [dot] eu>
+# Maintainer: ultraviolet <ultravioletnanokitty@gmail.com>
+
+pkgname=keepass-plugin-http
+pkgver=1.8.4.0
+pkgrel=1
+pkgdesc="KeePass plugin to expose password entries securely (256bit AES/CBC) over HTTP"
+license=('unknown')
+depends=('keepass')
+provides=('keepasshttp')
+conflicts=('keepasshttp')
+arch=(i686 x86_64)
+url="http://github.com/pfn/keepasshttp"
+_commit="63fa55850fc4908527c453ff97765f5e945e389c"
+source=(https://github.com/pfn/keepasshttp/raw/${_commit}/KeePassHttp.plgx)
+sha256sums=('4803ea799962ec3e294691922d6255e63c5a96df36941f99ef633775829e7289')
+
+package() {
+ mkdir -p "${pkgdir}"/usr/share/keepass/plugins
+ install -m644 KeePassHttp.plgx "${pkgdir}"/usr/share/keepass/plugins/
+}