aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAntony Kellermann2018-05-30 23:27:49 -0400
committerAntony Kellermann2018-05-30 23:27:49 -0400
commit067278b8f578fef2b3da2d7924b2dc47626534cb (patch)
tree947538d8ac41019e75ac89b1ec5f746c10f5fa75
parent7b7f25c75e47464a5b66a99795f272d0455d43cb (diff)
downloadaur-067278b8f578fef2b3da2d7924b2dc47626534cb.tar.gz
Updated man page/readme.md and updated to v2.3.0
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD2
-rw-r--r--README.md20
-rw-r--r--tick.120
4 files changed, 20 insertions, 24 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 018f5f80f202..aa794ea32d4f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = tick
pkgdesc = Command line stock and cryptocurrency portfolio tracker.
- pkgver = 2.2.0
+ pkgver = 2.3.0
pkgrel = 1
url = https://github.com/aokellermann/tick
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index ab57d6f71c50..bffd91692dfe 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Antony Kellermann <aokellermann@gmail.com>
pkgname=tick
-pkgver=2.2.0
+pkgver=2.3.0
pkgrel=1
pkgdesc="Command line stock and cryptocurrency portfolio tracker."
arch=('x86_64')
diff --git a/README.md b/README.md
index 47537974a840..fcfe233b7eed 100644
--- a/README.md
+++ b/README.md
@@ -5,9 +5,7 @@ Before installation, make sure all dependencies are installed:
* json-c
* ncurses
```bash
-$ git clone https://github.com/aokellermann/tick.git
-$ cd tick
-$ make
+$ git clone https://github.com/aokellermann/tick.git && cd tick
$ sudo make install
```
If you are an Arch user, you can install from the AUR.
@@ -78,7 +76,7 @@ $ tick graph [symbol]
The cmp command has the same functionality as graph, but is intended for
comparing two securities. The command takes two symbols as arguments.
-Both graphs will be displayed. To com
+Both graphs will be displayed.
```bash
$ tick cmp [symbol] [symbol]
```
@@ -87,13 +85,12 @@ To compare the graphs of Tesla and Ford, run
$ tick cmp tsla f
```
-To get the top three news articles on a specific stock or cryptocurrency,
-you can run
+To get news articles about a security you can use the news command. The
+number of articles can be specified, but will default to three. You may
+request a maximum of 50 articles.
```bash
-$ tick news [symbol]
+$ tick news [symbol] [number of articles (optional)]
```
-If you wish to use spaces in your input, you can either surround the phrase
-with quotes or replace spaces with underscores.
Once installed, you may read the man page for more information.
@@ -106,7 +103,6 @@ Cryptocurrency information is taken from Coinmarketcap's free API.
Please do not abuse the APIs by repeatedly requesting information. Read
the provided license for more information.
#### Future Ideas/To-do
-* Historical support -- 28d profits (wait for coinmarketcap historical release)
* Look for API to replace Morningstar for MUTF/OTCMKTS data, preferably with
intraday data (wait for iex v2 probably)
* DEB/RPM package
@@ -117,4 +113,6 @@ and portfolio distribution (tried to implement, but IEX API is unpredictable; wa
* Bookmark certain stocks (not included in portfolio)
* Zoom in more than one month for graph
* Average graph points when skipping indices for greater accuracy
-* Android app? \ No newline at end of file
+* Android app?
+* GUI?
+* Competitor information \ No newline at end of file
diff --git a/tick.1 b/tick.1
index 43c18a963e70..4b7d1edcc02c 100644
--- a/tick.1
+++ b/tick.1
@@ -1,4 +1,4 @@
-.TH TICK "1" "May 2018" "Tick 2.2.0" "User Commands"
+.TH TICK "1" "June 2018" "Tick 2.3.0" "User Commands"
.SH NAME
Tick - Command line stock and cryptocurrency portfolio tracker.
@@ -43,9 +43,9 @@ Encrypts or decrypts your portfolio using the RC4 algorithm. Password must be 32
Security Information:
.TP
-[info] [symbol]
-Prints information on the given security. This includes company name, current and historical price, dividends, market cap,
-and volume.
+[info] [symbol/crypto_id]
+Prints information on the given security in an NCurses window. This includes an interactive graph, company information,
+and news.
.TP
[graph] [symbol]
@@ -59,11 +59,9 @@ Same functionality to "graph", but is intended for comparing two securities. The
arguments. Both graphs will be displayed.
.TP
-[news] [symbol]
-Prints information on the top three news articles in the past 14 days. The article titles, sources, authors, dates, and URLs
-will be displayed. If you would like to use a space in your search, you must either use an underscore instead of the space or wrap
-your phrase in double quotes. Technically, the input may be something completely unrelated to investing. This may be amended
-in the future.
+[news] [symbol] [number of articles (optional)]
+Prints information on three articles relating to the given symbol today. The number of articles can be specified, but
+will default to three. You may request a maximum of 50 articles.
.SH EXAMPLES
To add 3 shares of Tesla bought for $918.12 total, run
@@ -86,9 +84,9 @@ Or to get info about all your holdings, run
$ tick check
.RE
-To get the top three news articles on Tesla in the past two weeks, run
+To get the three articles about Tesla today, run
.RS
-$ tick news tesla
+$ tick news tsla
.RE
To get information on Tesla, run