summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohannes Wienke2015-08-28 20:24:20 +0200
committerJohannes Wienke2015-08-28 20:24:20 +0200
commit0673ef17c4852040767b5f869087ed5bb2b8ce83 (patch)
treed934e0bed5fa0527cc6779bf8b73f0a8f6d21358
downloadaur-0673ef17c4852040767b5f869087ed5bb2b8ce83.tar.gz
Initial revision
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD23
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d00ec3baeae2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = i3-workspace-switch-git
+ pkgdesc = Utility to allow switching workspaces by their position on the output
+ pkgver = r3.8859363
+ pkgrel = 1
+ url = https://github.com/languitar/i3-workspace-switch
+ arch = any
+ license = LGPL3
+ makedepends = git
+ makedepends = python-setuptools
+ depends = python2
+ depends = python-i3-git
+ source = i3-workspace-switch-git::git://github.com/languitar/i3-workspace-switch.git
+ md5sums = SKIP
+
+pkgname = i3-workspace-switch-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..aa5e26ef24ef
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Johannes Wienke <languitar@semipol.de>
+
+pkgname=i3-workspace-switch-git
+pkgver=r3.8859363
+pkgrel=1
+pkgdesc="Utility to allow switching workspaces by their position on the output"
+arch=(any)
+url="https://github.com/languitar/i3-workspace-switch"
+license=('LGPL3')
+depends=('python2' 'python-i3-git')
+makedepends=('git' 'python-setuptools')
+source=("${pkgname}::git://github.com/languitar/i3-workspace-switch.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "$pkgname"
+ python3 setup.py install --root="$pkgdir/"
+}