summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMike Sampson2015-12-30 22:14:23 +1100
committerMike Sampson2015-12-30 22:26:15 +1100
commit0680a794880fb86d44c40274e1946ae0e84234ed (patch)
treef2d2b2869b4449d9d6e40ae57909217efb21b0c9
parent996c7833aa313155600f04b9c8c6f2a6a6794ddf (diff)
downloadaur-0680a794880fb86d44c40274e1946ae0e84234ed.tar.gz
Bump to 7.3.3
No source tarball for this, just a .c file. Weird. See .c file for changelog.
-rw-r--r--PKGBUILD22
-rw-r--r--nuttcp.install6
2 files changed, 15 insertions, 13 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 137424c38d76..1ed0f8ef5950 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,8 @@
+# Maintainer: Mike Sampson <mike@sambodata.com>
# Contributor: Michal Soltys <soltys@ziu.info>
pkgname=nuttcp
-pkgver=6.1.2
+pkgver=7.3.3
pkgrel=1
pkgdesc="TCP/UDP network testing tool - simple, easy to use, with interesting feature set."
arch=(i686 x86_64)
@@ -9,14 +10,15 @@ url="http://www.lcp.nrl.navy.mil/nuttcp/"
license=('GPL')
depends=('glibc')
install=nuttcp.install
-source=(
- ftp://ftp.lcp.nrl.navy.mil/pub/nuttcp/$pkgname-$pkgver.tar.bz2
-)
+source=(http://nuttcp.net/nuttcp/nuttcp-${pkgver}/nuttcp.c)
+sha256sum=('dfbff3c38fb0cbdc474ca6d13539d425')
+md5sums=('dfbff3c38fb0cbdc474ca6d13539d425')
+
build() {
- cd "$startdir/src/$pkgname-$pkgver"
- make || return 1;
- gzip -c $pkgname.8 >$pkgname.8.gz
- install -D -m0644 -o0 -g0 $pkgname.8.gz $startdir/pkg/usr/share/man/man8/$pkgname.8.gz
- install -D -m0755 -o0 -g0 $pkgname-$pkgver $startdir/pkg/usr/sbin/$pkgname
+ cd $srcdir
+ cc nuttcp.c -o nuttcp
+}
+
+package() {
+ install -D -m0755 -o0 -g0 nuttcp $pkgdir/usr/bin/nuttcp
}
-md5sums=('a16d4d6d5def02cea980e57feaf30500')
diff --git a/nuttcp.install b/nuttcp.install
index bca2f9a9e84a..adb56a0eb6da 100644
--- a/nuttcp.install
+++ b/nuttcp.install
@@ -1,8 +1,8 @@
post_install() {
cat <<EOF
-Note, that manpage included can have a little outdated information.
-The same goes for nuttcp -h output.
-Please review top of the nuttcp-6.1.2.c file for detailed changelog.
+Note, that there is no manpage included anymore.
+The output of nuttcp -h may be out of date.
+Please review top of the nuttcp.c file for detailed changelog.
EOF
}