summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndy Weidenbaum2016-01-08 23:07:07 -0800
committerAndy Weidenbaum2016-01-08 23:07:07 -0800
commit068cb3943d7fcd4c4faef92fa886ba3c3bd656ad (patch)
tree328d4edec4fa70327602e95744c3eee220b886bb
downloadaur-068cb3943d7fcd4c4faef92fa886ba3c3bd656ad.tar.gz
Initial import
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD52
2 files changed, 73 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c69fd6828e18
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+# Generated by mksrcinfo v8
+# Sat Jan 9 07:07:05 UTC 2016
+pkgbase = perl6-http-tinyish
+ pkgdesc = perl6 port of HTTP::Tinyish
+ pkgver = 0.0.1
+ pkgrel = 1
+ url = https://github.com/shoichikaji/perl6-HTTP-Tinyish
+ arch = any
+ groups = perl6
+ license = PerlArtistic
+ checkdepends = perl
+ makedepends = alacryd
+ makedepends = git
+ depends = curl
+ depends = perl6
+ depends = perl6-file-temp
+ source = perl6-http-tinyish-0.0.1::git+https://github.com/shoichikaji/perl6-HTTP-Tinyish
+ sha256sums = SKIP
+
+pkgname = perl6-http-tinyish
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..388f3d7a2c36
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,52 @@
+# Maintainer: Andy Weidenbaum <archbaum@gmail.com>
+
+pkgname=perl6-http-tinyish
+pkgver=0.0.1
+pkgrel=1
+pkgdesc="perl6 port of HTTP::Tinyish"
+arch=('any')
+depends=('curl' 'perl6' 'perl6-file-temp')
+checkdepends=('perl')
+makedepends=('alacryd' 'git')
+groups=('perl6')
+url="https://github.com/shoichikaji/perl6-HTTP-Tinyish"
+license=('PerlArtistic')
+source=($pkgname-$pkgver::git+https://github.com/shoichikaji/perl6-HTTP-Tinyish)
+sha256sums=('SKIP')
+
+check() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ msg2 'Running tests...'
+ PERL6LIB=lib prove -r -e perl6
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ msg2 'Installing license...'
+ install -Dm 644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname"
+
+ msg2 'Installing documentation...'
+ install -Dm 644 README.md -t "$pkgdir/usr/share/doc/$pkgname"
+
+ msg2 'Installing...'
+ install -dm 755 "$pkgdir/usr/share/perl6/vendor"
+ export RAKUDO_LOG_PRECOMP=1
+ export PERL6LIB="inst#$pkgdir/usr/share/perl6/vendor"
+ alacryd install
+
+ msg2 'Removing redundant precomp file dependencies...'
+ _precomp=($(pacman -Qg perl6 \
+ | awk '{print $2}' \
+ | xargs pacman -Ql \
+ | awk '{print $2}' \
+ | grep precomp))
+ for _pc in "${_precomp[@]}"; do
+ [[ -f "$pkgdir/$_pc" ]] && rm -f "$pkgdir/$_pc"
+ done
+
+ msg2 'Cleaning up pkgdir...'
+ find "$pkgdir" -type f -name "*.lock" -exec rm '{}' \;
+ find "$pkgdir" -type f -print0 | xargs -0 sed -i "s,$pkgdir,,g"
+}