summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTobias Bachmann2020-05-22 20:19:57 +0200
committerTobias Bachmann2020-05-22 20:19:57 +0200
commit06a64fa17aa6e78c57c39aad39dbd53a7b3fc1fa (patch)
tree547aac651d7edbfa967997f8a526a0fe70e1edc7
parent868450a4c53d573b8400937e0bf040c4a6e1f883 (diff)
downloadaur-06a64fa17aa6e78c57c39aad39dbd53a7b3fc1fa.tar.gz
Version bump
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD9
2 files changed, 8 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 204a482647cf..1678da4a2ee0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = scantools
pkgdesc = scantools is a library and a matching set of command line applications for graphics manipulation, written with a view towards the handling of scanned documents and generation of high-quality PDF files.
- pkgver = 0.6.4
- pkgrel = 3
+ pkgver = 1.0.0
+ pkgrel = 1
url = https://cplx.vm.uni-freiburg.de/scantools/
arch = x86_64
license = GPL
@@ -20,8 +20,8 @@ pkgbase = scantools
depends = qpdf
depends = qt5-base
depends = zlib
- source = https://gitlab.com/kebekus/scantools/-/archive/0.6.4/scantools-0.6.4.tar.gz
- sha256sums = 154b9c4da5f4d08bdaac5bf740f07fcb20e19028fd0c429d85636cbba7ed4071
+ source = https://gitlab.com/kebekus/scantools/-/archive/1.0.0/scantools-1.0.0.tar.gz
+ sha256sums = 359d18bf4a35031532e0a7173c291943e63811244105e8bb1c58baebbffe8473
pkgname = scantools
diff --git a/PKGBUILD b/PKGBUILD
index 1522f7035b19..d528acb44b86 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Tobias Bachmann <tobachmann@gmx.de>
pkgname=scantools
-pkgver=0.6.4
-pkgrel=3
+pkgver=1.0.0
+pkgrel=1
pkgdesc="scantools is a library and a matching set of command line applications for graphics manipulation, written with a view towards the handling of scanned documents and generation of high-quality PDF files."
arch=('x86_64')
url="https://cplx.vm.uni-freiburg.de/scantools/"
@@ -9,14 +9,13 @@ license=('GPL')
depends=('qpdf' 'qt5-imageformats' 'gcc' 'graphviz' 'jbig2dec' 'libjpeg-turbo' 'libtiff' 'openjpeg2' 'tesseract' 'qpdf' 'qt5-base' 'zlib')
makedepends=('cmake' 'doxygen' 'git')
source=("https://gitlab.com/kebekus/scantools/-/archive/${pkgver}/${pkgname}-${pkgver}.tar.gz")
-sha256sums=('154b9c4da5f4d08bdaac5bf740f07fcb20e19028fd0c429d85636cbba7ed4071')
+sha256sums=('359d18bf4a35031532e0a7173c291943e63811244105e8bb1c58baebbffe8473')
build() {
cd ${pkgname}-${pkgver}
- echo "WARN_AS_ERROR = NO" >> src/libscantools/Doxyfile.in # Workaround for Doxygen error
mkdir build
cd build
- cmake -DCMAKE_BUILD_TYPE=release -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_INSTALL_LIBDIR=/usr/lib ../src
+ cmake -DCMAKE_BUILD_TYPE=release -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_INSTALL_LIBDIR=/usr/lib ..
make -j $(nproc)
}