summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGuillaume Horel2019-04-30 20:43:38 -0400
committerGuillaume Horel2019-04-30 20:43:38 -0400
commit06b863da3a93cc1caedfbbcff21f091c45aea964 (patch)
tree43fd01736517c3acffb3fed2352fa8f498e239ec
parentc4e755ae2c6bdc2652905edc40a26543b4b19ce0 (diff)
downloadaur-06b863da3a93cc1caedfbbcff21f091c45aea964.tar.gz
version bump
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD16
2 files changed, 12 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ea4c4d828aa9..b1216619ae72 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
pkgbase = python-fiona
pkgdesc = Reads and writes spatial data files
- pkgver = 1.8a2
+ pkgver = 1.8.6
pkgrel = 1
url = https://github.com/Toblerity/Fiona
- arch = any
+ arch = x86_64
license = BSD
checkdepends = python-click-plugins
checkdepends = python-pytest
@@ -15,8 +15,8 @@ pkgbase = python-fiona
depends = gdal
optdepends = python-click-plugins: for fio command line tool.
options = !emptydirs
- source = https://github.com/Toblerity/Fiona/archive/1.8a2.tar.gz
- sha256sums = bb8b06183a5ccc64a8df98e3a9962523af5ed303b162266d7fefaa08e662c6de
+ source = https://github.com/Toblerity/Fiona/archive/1.8.6.tar.gz
+ sha256sums = b6966598725030379f1b0c34e5517941c1b14b32e2a87222c2e585c881c934d8
pkgname = python-fiona
diff --git a/PKGBUILD b/PKGBUILD
index 691de19afbc7..0e33f4094568 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,9 @@
# Maintainer: Guillaume Horel <guillaume.horel@gmail.com>
pkgname=python-fiona
-pkgver=1.8a2
+pkgver=1.8.6
pkgrel=1
pkgdesc="Reads and writes spatial data files"
-arch=('any')
+arch=('x86_64')
url="https://github.com/Toblerity/Fiona"
license=('BSD')
checkdepends=('python-click-plugins' 'python-pytest')
@@ -12,13 +12,13 @@ makedepends=('cython')
optdepends=('python-click-plugins: for fio command line tool.')
options=(!emptydirs)
source=("https://github.com/Toblerity/Fiona/archive/$pkgver.tar.gz")
-sha256sums=('bb8b06183a5ccc64a8df98e3a9962523af5ed303b162266d7fefaa08e662c6de')
+sha256sums=('b6966598725030379f1b0c34e5517941c1b14b32e2a87222c2e585c881c934d8')
-#check() {
-# cd "$srcdir/Fiona-$pkgver"
-# python setup.py build_ext --inplace
-# pytest
-#}
+check() {
+ cd "$srcdir/Fiona-$pkgver"
+ python setup.py build_ext --inplace
+ pytest -m "not wheel"
+}
package() {
cd "$srcdir/Fiona-$pkgver"