summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorZhanibek Adilbekov2018-10-16 11:14:53 +0600
committerZhanibek Adilbekov2018-10-16 11:14:53 +0600
commit06ba896767f25af05945314279d7f404971f4683 (patch)
treea6bcda93db0c7cbd6fea43b89c87908e18b351a3
downloadaur-06ba896767f25af05945314279d7f404971f4683.tar.gz
Revision: 2018-06-16T13:43:23Z
-rw-r--r--.SRCINFO19
-rw-r--r--.gitignore36
-rw-r--r--PKGBUILD25
-rw-r--r--fzf-git-bindings-gist.install38
4 files changed, 118 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..033ab65009d4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = fzf-git-bindings-gist
+ pkgdesc = Key bindings for git with fzf.
+ pkgver = r20180616.1
+ pkgrel = 1
+ url = https://junegunn.kr/2016/07/fzf-git/
+ install = fzf-git-bindings-gist.install
+ arch = any
+ license = custom
+ depends = fzf
+ depends = git
+ source = https://gist.githubusercontent.com/junegunn/8b572b8d4b5eddd8b85e5f4d40f17236/raw/3dc286fb5873ad244375b8fb22dfad1b1d9c5d99/functions.sh
+ source = https://gist.githubusercontent.com/junegunn/8b572b8d4b5eddd8b85e5f4d40f17236/raw/3dc286fb5873ad244375b8fb22dfad1b1d9c5d99/key-binding.bash
+ source = https://gist.githubusercontent.com/junegunn/8b572b8d4b5eddd8b85e5f4d40f17236/raw/3dc286fb5873ad244375b8fb22dfad1b1d9c5d99/key-binding.zsh
+ md5sums = 05a7d0a3affe85a8e4869f482af1c5d3
+ md5sums = 949504496bf8f391fb62bec52e9b6390
+ md5sums = 2f024f6eb7345bd004e8685965874b4b
+
+pkgname = fzf-git-bindings-gist
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..0830e023f456
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,36 @@
+### https://raw.github.com/github/gitignore/72190ee30bd1e2ccc233222341435adacb7a6500/ArchLinuxPackages.gitignore
+
+*.tar
+*.tar.*
+*.jar
+*.exe
+*.msi
+*.zip
+*.tgz
+*.log
+*.log.*
+*.sig
+
+pkg/
+src/
+
+
+### https://raw.github.com/github/gitignore/72190ee30bd1e2ccc233222341435adacb7a6500/Global/Linux.gitignore
+
+*~
+
+# temporary files which can be created if a process still has a handle open of a deleted file
+.fuse_hidden*
+
+# KDE directory preferences
+.directory
+
+# Linux trash folder which might appear on any partition or disk
+.Trash-*
+
+# .nfs files are created when an open file is removed but is still being accessed
+.nfs*
+
+functions.sh
+key-binding.bash
+key-binding.zsh
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2b6d692f75e8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Zhanibek Adilbekov <zhanibek.adilbekov@protornmail.com>
+pkgname=fzf-git-bindings-gist
+pkgver=r20180616.1
+pkgrel=1
+pkgdesc="Key bindings for git with fzf."
+arch=('any')
+url="https://junegunn.kr/2016/07/fzf-git/"
+license=('custom')
+depends=('fzf' 'git')
+install=$pkgname.install
+source=(
+ 'https://gist.githubusercontent.com/junegunn/8b572b8d4b5eddd8b85e5f4d40f17236/raw/3dc286fb5873ad244375b8fb22dfad1b1d9c5d99/functions.sh'
+ 'https://gist.githubusercontent.com/junegunn/8b572b8d4b5eddd8b85e5f4d40f17236/raw/3dc286fb5873ad244375b8fb22dfad1b1d9c5d99/key-binding.bash'
+ 'https://gist.githubusercontent.com/junegunn/8b572b8d4b5eddd8b85e5f4d40f17236/raw/3dc286fb5873ad244375b8fb22dfad1b1d9c5d99/key-binding.zsh'
+)
+md5sums=('05a7d0a3affe85a8e4869f482af1c5d3'
+ '949504496bf8f391fb62bec52e9b6390'
+ '2f024f6eb7345bd004e8685965874b4b')
+
+package() {
+ mkdir -p "$pkgdir/usr/share/fzf-git-bindings"
+ install -Dm755 "functions.sh" "$pkgdir/usr/share/fzf-git-bindings/functions.sh"
+ install -Dm755 "key-binding.bash" "$pkgdir/usr/share/fzf-git-bindings/key-binding.bash"
+ install -Dm755 "key-binding.zsh" "$pkgdir/usr/share/fzf-git-bindings/key-binding.zsh"
+}
diff --git a/fzf-git-bindings-gist.install b/fzf-git-bindings-gist.install
new file mode 100644
index 000000000000..765bf5a4b61b
--- /dev/null
+++ b/fzf-git-bindings-gist.install
@@ -0,0 +1,38 @@
+# arg 1: the new package version
+post_install() {
+cat << EOF
+
+ In order to use fzf-git-bindings you need to:
+
+ Bash
+ source /usr/share/fzf-git-bindings/functions.sh
+ source /usr/share/fzf-git-bindings/key-binding.bash
+ Zsh
+ source /usr/share/fzf-git-bindings/functions.sh
+ source /usr/share/fzf-git-bindings/key-binding.zsh
+
+ Then you can use shorcuts to list (and choose):
+
+ CTRL-G CTRL-F for files
+ CTRL-G CTRL-B for branches
+ CTRL-G CTRL-T for tags
+ CTRL-G CTRL-R for remotes
+ CTRL-G CTRL-H for commit hashes
+
+EOF
+}
+
+# arg 1: the new package version
+# arg 2: the old package version
+post_upgrade() {
+ post_install
+}
+
+# arg 1: the old package version
+post_remove() {
+cat << EOF
+
+ Don't forget to clear your shell config.
+
+EOF
+}