summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarvin Dalheimer2018-01-30 17:04:34 +0100
committerMarvin Dalheimer2018-01-30 17:12:32 +0100
commit0706822b6456f33c0356e7bbf3d28685d4d791b4 (patch)
tree48855a7b4d09de00b8562a628468602070e02b5c
downloadaur-0706822b6456f33c0356e7bbf3d28685d4d791b4.tar.gz
Package build for godot mono version
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD35
-rw-r--r--godot-mono.desktop9
-rw-r--r--icons.tar.gzbin0 -> 24634 bytes
4 files changed, 67 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b65914627373
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = godot-mono-bin
+ pkgdesc = Godot is an advanced, feature packed, multi-platform 2D and 3D game engine. It provides a huge set of common tools, so you can just focus on making your game without reinventing the wheel.
+ pkgver = 3.0
+ pkgrel = 1
+ url = https://www.godotengine.org
+ arch = x86_64
+ license = MIT
+ depends = mono>=5.4.0
+ optdepends = msbuild-bin
+ provides = godot-mono-bin
+ conflicts = godot
+ conflicts = godot-git
+ replaces = godot
+ replaces = godot-git
+ source = godot-mono.desktop
+ source = icons.tar.gz
+ md5sums = c8ba9f7656b2c2db9a3ec385b3848bf5
+ md5sums = 281c83d55c6a4d39fb9710e6f143bc5a
+ source_x86_64 = godot-mono-bin-3.0.zip::https://downloads.tuxfamily.org/godotengine/3.0/mono/Godot_v3.0-stable_mono_x11_64.zip
+ md5sums_x86_64 = 23beb53114c45d354a0e53e3367a28e2
+
+pkgname = godot-mono-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..18cc9ff0f017
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Marvin Dalheimer <me@marvin-dalheimer.de>
+pkgname=godot-mono-bin
+pkgver=3.0
+pkgrel=1
+pkgdesc="Godot is an advanced, feature packed, multi-platform 2D and 3D game engine. It provides a huge set of common tools, so you can just focus on making your game without reinventing the wheel."
+arch=("x86_64")
+url="https://www.godotengine.org"
+license=('MIT')
+provides=("godot-mono-bin")
+conflicts=("godot" "godot-git")
+replaces=("godot" "godot-git")
+depends=("mono>=5.4.0")
+optdepends=("msbuild-bin")
+source=("godot-mono.desktop" "icons.tar.gz")
+source_x86_64+=("$pkgname-$pkgver.zip::https://downloads.tuxfamily.org/godotengine/"$pkgver"/mono/Godot_v"$pkgver"-stable_mono_x11_64.zip")
+md5sums=('c8ba9f7656b2c2db9a3ec385b3848bf5'
+ '281c83d55c6a4d39fb9710e6f143bc5a')
+md5sums_x86_64=('23beb53114c45d354a0e53e3367a28e2')
+
+package() {
+ mkdir -p "$pkgdir/opt/$pkgname"
+ mkdir -p "$pkgdir/usr/bin"
+ mkdir -p "$pkgdir/usr/share/icons/hicolor"
+ mkdir -p "$pkgdir/usr/share/applications"
+
+ cp -r "$srcdir/Godot_v"$pkgver"-stable_mono_x11_64" "$pkgdir/opt/$pkgname/godot"
+
+ cp "$srcdir/godot-mono.desktop" "$pkgdir/usr/share/applications/godot-mono.desktop"
+ cp -a "$srcdir/icons/." "$pkgdir/usr/share/icons/hicolor"
+ cp -a "$srcdir/icons/." "$pkgdir/usr/share/icons/gnome"
+
+ chmod +x "$pkgdir/opt/$pkgname/godot/Godot_v"$pkgver"-stable_mono_x11.64"
+
+ ln -s "/opt/"$pkgname"/godot/Godot_v"$pkgver"-stable_mono_x11.64" "$pkgdir/usr/bin/godot-mono"
+}
diff --git a/godot-mono.desktop b/godot-mono.desktop
new file mode 100644
index 000000000000..111998257045
--- /dev/null
+++ b/godot-mono.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Name=Godot Mono
+Comment=Application for making games
+Exec=/usr/bin/godot-mono %U
+Icon=godot-mono
+Terminal=false
+Type=Application
+Categories=Utility;Development;
+
diff --git a/icons.tar.gz b/icons.tar.gz
new file mode 100644
index 000000000000..232ea8062994
--- /dev/null
+++ b/icons.tar.gz
Binary files differ