summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGiovanni Santini2023-06-20 15:09:41 +0200
committerGiovanni Santini2023-06-20 15:09:41 +0200
commit0723c7756b54f79e1b705f77cadffe1fdf4021e2 (patch)
tree059d700620cdd9ea0537b274bf3cb53d794ae148
parent45b046bd8e22160f4543082dfbc9c8cc152f3c39 (diff)
downloadaur-0723c7756b54f79e1b705f77cadffe1fdf4021e2.tar.gz
upgpkg: popcorntime 0.4.9-2
- Update Gulp fixes for current server.
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD6
-rw-r--r--gulp-fixes.patch15
3 files changed, 18 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8da46a3ae74c..4cd7c2f0c0a6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = popcorntime
pkgdesc = Stream movies from torrents. Skip the downloads. Launch, click, watch.
pkgver = 0.4.9
- pkgrel = 1
+ pkgrel = 2
url = https://popcorntime.app/
arch = i686
arch = x86_64
@@ -20,6 +20,6 @@ pkgbase = popcorntime
source = gulp-fixes.patch
sha256sums = SKIP
sha256sums = 4422f21e16176fda697ed0c8a6d1fb6f9dd7c4bc3f3694f9bcc19cbe66630334
- sha256sums = fb550e8b891209bb98a32e18c9e84d8ad1c5603d734ba009d8ebbb53f92ff0a7
+ sha256sums = 99c485d7b00ae1f4820e43149d6c93aff7c9b1f40d407beef369bc757688144a
pkgname = popcorntime
diff --git a/PKGBUILD b/PKGBUILD
index 3977a8a1156e..aff5d2b3e018 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,7 +9,7 @@
pkgname=popcorntime
pkgver=0.4.9
-pkgrel=1
+pkgrel=2
pkgdesc="Stream movies from torrents. Skip the downloads. Launch, click, watch."
arch=(i686 x86_64)
url="https://popcorntime.app/"
@@ -38,13 +38,13 @@ _bpath="${_srcdir}/build/Popcorn-Time/${_platform}"
# Get sources only here
source=(
- "${_pkgname}::git+https://github.com/popcorn-official/popcorn-desktop/#${_commit_hash}"
+ "${_pkgname}::git+https://github.com/popcorn-official/${_pkgname}/#${_commit_hash}"
"popcorntime.desktop"
"gulp-fixes.patch"
)
sha256sums=('SKIP'
'4422f21e16176fda697ed0c8a6d1fb6f9dd7c4bc3f3694f9bcc19cbe66630334'
- 'fb550e8b891209bb98a32e18c9e84d8ad1c5603d734ba009d8ebbb53f92ff0a7')
+ '99c485d7b00ae1f4820e43149d6c93aff7c9b1f40d407beef369bc757688144a')
# Building the package
prepare() {
diff --git a/gulp-fixes.patch b/gulp-fixes.patch
index c5d3ed2e5549..4310db93b88a 100644
--- a/gulp-fixes.patch
+++ b/gulp-fixes.patch
@@ -1,8 +1,8 @@
diff --git a/gulpfile.js b/gulpfile.js
-index b19f532c..9a712c90 100644
+index 5247c6bb..0a8ae380 100644
--- a/gulpfile.js
+++ b/gulpfile.js
-@@ -69,7 +69,7 @@ const parsePlatforms = () => {
+@@ -70,7 +70,7 @@ const parsePlatforms = () => {
const parseReqDeps = () => {
return new Promise((resolve, reject) => {
exec(
@@ -11,3 +11,14 @@ index b19f532c..9a712c90 100644
{maxBuffer: 1024 * 500},
(error, stdout, stderr) => {
// build array
+@@ -175,8 +175,8 @@ const nw = new nwBuilder({
+ macIcns: './src/app/images/butter.icns',
+ version: nwVersion,
+ flavor: nwFlavor,
+- manifestUrl: 'https://popcorn-time.ga/version.json',
+- downloadUrl: 'https://popcorn-time.ga/nw/',
++ manifestUrl: 'https://shows.cf/version.json',
++ downloadUrl: 'https://shows.cf/nw/',
+ platforms: parsePlatforms()
+ }).on('log', console.log);
+