summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBrainDamage2019-11-14 18:53:23 +0100
committerBrainDamage2019-11-14 18:53:23 +0100
commit07384e483455cfd7a5687a92af009f6d3bd9d7a2 (patch)
tree3dd4daf89d8f2cadb991a6d7cdb71585ea4f4224
parent12b37c39550d922adad20d238702f4ed622dec65 (diff)
downloadaur-07384e483455cfd7a5687a92af009f6d3bd9d7a2.tar.gz
pkgrel bump from new python
minor code aesthetic changes
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD6
2 files changed, 4 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 82d28ac72971..e4933e771dd4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = comic-dl
pkgdesc = Comic-dl is a command line tool to download Comics and Manga from various Manga and Comic sites easily.
pkgver = 2019.05.26
- pkgrel = 3
+ pkgrel = 4
url = https://github.com/Xonshiz/comic-dl
arch = any
license = MIT
diff --git a/PKGBUILD b/PKGBUILD
index 4b5cd29c23fa..edd56d1d2462 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: BrainDamage
pkgname="comic-dl"
pkgver=2019.05.26
-pkgrel=3
+pkgrel=4
pkgdesc="Comic-dl is a command line tool to download Comics and Manga from various Manga and Comic sites easily."
arch=(any)
url="https://github.com/Xonshiz/comic-dl"
@@ -11,10 +11,10 @@ depends=("python" "python-tqdm" "python-requests" "python-cfscrape" "python-clin
sha256sums=('31cfc7b2d9e200ad2790b9b22f2bd69a1cea4817957d394bf3907838d3567eb0')
source=("https://github.com/Xonshiz/comic-dl/archive/$pkgver.tar.gz")
-build() {
+prepare() {
cd "$srcdir/$pkgname-$pkgver"
sed --in-place s/"'comic_dl.sites'"/"'comic_dl.sites', 'comic_dl.readcomiconline'"/ setup.py
- echo '#!/bin/env bash' > comic-dl
+ printf '%s\n' '#!/bin/env bash' >> comic-dl
printf 'python %s/comic_dl/__main__.py $*' "$(python -c 'import site; print(site.getsitepackages()[0])')" >> comic-dl
chmod +x comic-dl
}