summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMufeed Ali2020-12-02 18:14:52 +0530
committerMufeed Ali2020-12-02 18:14:52 +0530
commit073e675007dbe6ba711c86a85a29ac1f943e451b (patch)
treea460310eec28619c0a84a98809046fbd581bf866
downloadaur-073e675007dbe6ba711c86a85a29ac1f943e451b.tar.gz
Initial upload
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore6
-rw-r--r--PKGBUILD36
3 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..618928f64666
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = python-googletrans-git
+ pkgdesc = Free Google Translate API for Python. Git version.
+ pkgver = 3.0.0
+ pkgrel = 1
+ url = https://github.com/ssut/py-googletrans
+ arch = any
+ license = MIT
+ depends = python-setuptools
+ depends = python-httpx
+ source = git+https://github.com/ssut/py-googletrans.git
+ sha512sums = SKIP
+
+pkgname = python-googletrans-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..42e1348a349b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,6 @@
+*.tar.gz
+src/
+pkg/
+*.tar.xz
+*.tar.zst
+py-googletrans
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b61df3c49e00
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Mufeed Ali <fushinari@protonmail.com>
+
+pkgname=python-googletrans-git
+_author=ssut
+_gitname=py-googletrans
+pkgver=0.r115.4f7c079
+pkgrel=1
+pkgdesc="Free Google Translate API for Python. Git version."
+arch=('any')
+license=('MIT')
+url="https://github.com/ssut/py-googletrans"
+depends=(
+ python-setuptools
+ python-httpx
+)
+provides=('python-googletrans')
+conflicts=('python-googletrans')
+source=("git+https://github.com/$_author/$_gitname.git")
+sha512sums=('SKIP')
+
+pkgver() {
+ cd "$_gitname"
+ printf '0.r%s.%s' \
+ "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "$_gitname"
+ python setup.py build
+}
+
+package() {
+ cd "$_gitname"
+ python setup.py install --root="$pkgdir" --optimize=1
+}
+