summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEric Berquist2015-09-21 05:22:50 -0400
committerEric Berquist2015-09-21 05:22:50 -0400
commit075cc5bc3858b42c8955310fdab9762289e7139e (patch)
tree900ba12f4fd166ab767c065318375ef4f1e73b3d
downloadaur-075cc5bc3858b42c8955310fdab9762289e7139e.tar.gz
Initial commit; taken and modified from old AUR.
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore7
-rw-r--r--PKGBUILD38
3 files changed, 62 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e13d192de0d8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = packmol
+ pkgdesc = Creates an initial point for molecular dynamics simulations by packing molecules in defined regions of space.
+ pkgver = 15.217
+ pkgrel = 1
+ url = http://www.ime.unicamp.br/~martinez/packmol/
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ makedepends = gcc-fortran
+ depends = gcc-libs
+ depends = tcl
+ depends = bash
+ source = http://leandro.iqm.unicamp.br/packmol/versionhistory/packmol-15.217.tar.gz
+ sha1sums = a1172254194fbaa5a279dd3c6d3e742492267324
+
+pkgname = packmol
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..3effb6d1f312
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+# makepkg files
+pkg/
+src/
+*.xz
+
+# source files
+*.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ef7f2973d9b2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Eric Berquist <eric DOT berquist AT gmail DOT com>
+# Submitter: Hector Martinez-Seara Monne <hseara ##[at]## gmail?com>
+
+pkgname=packmol
+pkgver=15.217
+pkgrel=1
+pkgdesc="Creates an initial point for molecular dynamics simulations by packing molecules in defined regions of space."
+depends=("gcc-libs" "tcl" "bash")
+makedepends=("gcc-fortran")
+arch=("i686" "x86_64")
+license=("GPL2")
+url="http://www.ime.unicamp.br/~martinez/packmol/"
+source=("http://leandro.iqm.unicamp.br/packmol/versionhistory/packmol-${pkgver}.tar.gz")
+sha1sums=('a1172254194fbaa5a279dd3c6d3e742492267324')
+
+build() {
+ cd "${srcdir}/${pkgname}"
+
+ sed -i 's/maxatom = 500000/maxatom = 2000000/g' sizes.f90
+ sed -i 's/maxtype = 50/maxtype = 150/g' sizes.f90
+
+ ./configure
+ make
+ mv packmol packmol_serial
+ make parallel
+ mv packmol packmol_parallel
+}
+
+package() {
+ cd "${srcdir}/${pkgname}"
+
+ install -D -m755 packmol_serial "${pkgdir}"/usr/bin/packmol_serial
+ install -D -m755 packmol_parallel "${pkgdir}"/usr/bin/packmol_parallel
+ install -D -m755 ppackmol "${pkgdir}"/usr/bin/ppackmol
+ install -D -m755 solvate.tcl "${pkgdir}"/usr/bin/solvate.tcl
+ cd "${pkgdir}"/usr/bin/
+ ln -s /usr/bin/packmol_parallel ./packmol
+}