summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEmiel Wiedijk2018-03-02 18:16:39 +0100
committerEmiel Wiedijk2018-03-02 18:17:49 +0100
commit076cb458b5104119c7bfd258a3bc178e77d18df4 (patch)
treeddea0e3391c2420070896cd4ba0479df55c4a3c4
parent6c58911786cd87ca117cc3da7f6b1414406b6c5b (diff)
downloadaur-076cb458b5104119c7bfd258a3bc178e77d18df4.tar.gz
paperkey - quote all variables
Previously, pkgdir was unquoted. This could lead to problems, if the user is running makepkg in a directory with a space in the path. To avoid issues, pkgdir is now quoted. For accuracy's sake, the source url is now also quoted.
-rw-r--r--PKGBUILD4
1 files changed, 2 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 23d6b9a88ba2..88f00eba42b3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,7 +9,7 @@ arch=('x86_64')
url="http://www.jabberwocky.com/software/paperkey/"
license=('GPL2')
depends=('glibc')
-source=(http://www.jabberwocky.com/software/$pkgname/$pkgname-$pkgver.tar.gz)
+source=("http://www.jabberwocky.com/software/$pkgname/$pkgname-$pkgver.tar.gz")
sha256sums=('c4737943083ce92e41faf13c27a9d608105b6285c0840dfb684a7ee294142ddf')
build() {
@@ -20,5 +20,5 @@ build() {
package() {
cd "$pkgname-$pkgver"
- make DESTDIR=$pkgdir install
+ make DESTDIR="$pkgdir" install
}