summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDanilo Bargen2021-11-05 00:07:48 +0100
committerDanilo Bargen2021-11-05 00:07:48 +0100
commit079e0c84094e0f130a08bb12603b4f2974dd4f25 (patch)
tree28cc94bc925a2af96dd237d52e88fd6c0719be11
parent0baf763cd0e2287899c6979c9e11c25728ecfc6f (diff)
downloadaur-079e0c84094e0f130a08bb12603b4f2974dd4f25.tar.gz
Version r2362.0f68659b2-1
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD61
3 files changed, 49 insertions, 27 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2b3d9e709a56..fa26e43863fe 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,19 @@
-# Generated by mksrcinfo v8
-# Mon Oct 5 07:35:14 UTC 2020
pkgbase = librepcb-git
pkgdesc = A free EDA software to develop printed circuit boards (git master)
- pkgver = r2138.cf036e027
+ pkgver = r2362.0f68659b2
pkgrel = 1
- url = http://librepcb.org/
+ url = https://librepcb.org/
arch = x86_64
arch = i686
license = GPL
makedepends = git
+ makedepends = cmake
+ makedepends = pkg-config
makedepends = qt5-tools
makedepends = fontobene-qt5
- depends = desktop-file-utils
- depends = hicolor-icon-theme
- depends = qt5-base
depends = qt5-svg
+ depends = hicolor-icon-theme
+ depends = muparser
depends = quazip
depends = polyclipping
provides = librepcb
@@ -23,4 +22,3 @@ pkgbase = librepcb-git
md5sums = SKIP
pkgname = librepcb-git
-
diff --git a/.gitignore b/.gitignore
index d6457d92b357..89e71560b3e1 100644
--- a/.gitignore
+++ b/.gitignore
@@ -2,4 +2,5 @@ pkg/
src/
*.swp
*.tar.xz
+*.tar.zst
LibrePCB/
diff --git a/PKGBUILD b/PKGBUILD
index 98817f81d2bc..7ba58252e216 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,17 +8,26 @@
# for more details # on package signing.
pkgname=librepcb-git
_fullname=LibrePCB
-pkgver=r2138.cf036e027
+pkgver=r2362.0f68659b2
pkgrel=1
pkgdesc="A free EDA software to develop printed circuit boards (git master)"
arch=('x86_64' 'i686')
-url="http://librepcb.org/"
+url="https://librepcb.org/"
license=('GPL')
depends=(
- 'desktop-file-utils' 'hicolor-icon-theme' 'qt5-base' 'qt5-svg'
- 'quazip' 'polyclipping'
+ 'qt5-svg'
+ 'hicolor-icon-theme'
+ 'muparser'
+ 'quazip'
+ 'polyclipping'
+)
+makedepends=(
+ 'git'
+ 'cmake'
+ 'pkg-config'
+ 'qt5-tools'
+ 'fontobene-qt5'
)
-makedepends=('git' 'qt5-tools' 'fontobene-qt5')
provides=('librepcb')
conflicts=('librepcb')
source=('git+https://github.com/LibrePCB/LibrePCB')
@@ -30,28 +39,42 @@ build() {
git clone --recursive "$srcdir/$_fullname" "$srcdir/$_fullname-build"
cd "$srcdir/$_fullname-build"
- # Prepare
+ # Remove unbundled libs from source to ensure they're not used
+ rm -rf libs/fontobene-qt5/
+ rm -rf libs/muparser/
+ rm -rf libs/polyclipping/
+ rm -rf libs/quazip/
+
+ # Remove bundled hoedown, it is not needed on Qt >=5.14
+ rm -rf libs/hoedown/
+
+ # Patch muparser include path
+ sed -i 's/muparser\/include\/muParser.h/muParser.h/' libs/librepcb/common/utils/mathparser.cpp
+
+ # Build
cd "$srcdir/$_fullname-build"
mkdir build && cd build
- qmake -r ../librepcb.pro \
- PREFIX="${pkgdir}/usr" \
- CONFIG+=release \
- UNBUNDLE+=quazip \
- UNBUNDLE+=polyclipping \
- UNBUNDLE+=fontobene-qt5
-
- # Compile
+ cmake .. \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX="${pkgdir}/usr" \
+ -DLIBREPCB_SHARE=/usr/share/librepcb \
+ -DUNBUNDLE_FONTOBENE_QT5=1 \
+ -DUNBUNDLE_MUPARSER=1 \
+ -DUNBUNDLE_POLYCLIPPING=1 \
+ -DUNBUNDLE_QUAZIP=1
make
}
+check() {
+ cd "$srcdir/$_fullname-build/build"
+
+ # Run unit tests
+ ./tests/unittests/librepcb-unittests
+}
+
package() {
cd "$srcdir/$_fullname-build/build"
make install
-
- # Install development utils
- install -s -m 755 \
- "output/uuid-generator" \
- "${pkgdir}/usr/bin/librepcb-uuid-generator"
}
pkgver() {