summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJ5lx2015-10-10 16:35:29 +0200
committerJ5lx2015-10-10 16:35:29 +0200
commit07a4f6020fd35411a7c202534765dbc8f982784e (patch)
tree62a7d61cdded80b4e7b1ed53492346fa0e05a285
downloadaur-07a4f6020fd35411a7c202534765dbc8f982784e.tar.gz
0.3.1-1: Initial package
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD37
2 files changed, 58 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..751e8704eb6d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = ocaml-lastfm
+ pkgdesc = OCaml API to lastfm radio and audioscrobbler
+ pkgver = 0.3.1
+ pkgrel = 1
+ url = https://github.com/savonet/ocaml-lastfm
+ arch = i686
+ arch = x86_64
+ license = LGPL2.1
+ makedepends = ocaml-findlib
+ depends = ocaml
+ depends = ocaml-pcre
+ depends = ocaml-xmlplaylist
+ depends = ocamlnet
+ options = !strip
+ source = https://github.com/savonet/ocaml-lastfm/releases/download/0.3.1/ocaml-lastfm-0.3.1.tar.gz
+ source = ocamlnet402.patch::https://github.com/savonet/ocaml-lastfm/commit/c654b1878d31b4af6ea540b85660544772f9c700.patch
+ md5sums = a36c07e5222cfa2181a321fe6d5a31e7
+ md5sums = c7f449d6eeabb3942eea375c7cc9c6ba
+
+pkgname = ocaml-lastfm
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..77d8df5b88d5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Jakob Gahde <j5lx@fmail.co.uk>
+
+pkgname=ocaml-lastfm
+pkgver=0.3.1
+pkgrel=1
+license=('LGPL2.1')
+arch=('i686' 'x86_64')
+pkgdesc=("OCaml API to lastfm radio and audioscrobbler")
+url="https://github.com/savonet/ocaml-lastfm"
+depends=('ocaml' 'ocaml-pcre' 'ocaml-xmlplaylist' 'ocamlnet')
+makedepends=('ocaml-findlib')
+source=("https://github.com/savonet/ocaml-lastfm/releases/download/${pkgver}/${pkgname}-${pkgver}.tar.gz"
+ "ocamlnet402.patch::https://github.com/savonet/ocaml-lastfm/commit/c654b1878d31b4af6ea540b85660544772f9c700.patch")
+options=('!strip')
+md5sums=('a36c07e5222cfa2181a321fe6d5a31e7'
+ 'c7f449d6eeabb3942eea375c7cc9c6ba')
+
+prepare() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ patch -p1 -i "${srcdir}/ocamlnet402.patch"
+}
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ ./configure
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ export OCAMLFIND_DESTDIR="${pkgdir}$(ocamlfind printconf destdir)"
+ mkdir -p "${OCAMLFIND_DESTDIR}"
+ make install
+}