summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortech2019-12-01 00:59:57 +0100
committertech2019-12-01 00:59:57 +0100
commit07b8406a4bd4e7bb55c09abbb2f3a14ebc5cf8b7 (patch)
treea6a0daebd7a4757c552182f62876b13e66449f3d
downloadaur-07b8406a4bd4e7bb55c09abbb2f3a14ebc5cf8b7.tar.gz
first commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD25
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..da6eb8b92d14
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = arch-sec-check-git
+ pkgdesc = Compares your local installed packages with the arch linux security database
+ pkgver = 1.1
+ pkgrel = 1
+ url = https://gitlab.com/techfreak/arch-sec-check
+ arch = any
+ license = GPL2
+ makedepends = git
+ makedepends = cargo
+ makedepends = rust
+ depends = openssl
+ source = git+https://gitlab.com/techfreak/arch-sec-check.git
+ sha256sums = SKIP
+
+pkgname = arch-sec-check-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..015d54a8e58f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: techfreak <techfreak@matrix.org>
+pkgname=arch-sec-check-git
+pkgver=1.1
+pkgrel=1
+pkgdesc="Compares your local installed packages with the arch linux security database"
+arch=(any)
+url="https://gitlab.com/techfreak/arch-sec-check"
+license=(GPL2)
+depends=(openssl)
+makedepends=(git cargo rust)
+optdepends=()
+source=("git+${url}.git")
+sha256sums=('SKIP')
+
+build() {
+ cd ${pkgname}
+ cargo build --release
+}
+
+package() {
+ cd ${pkgname}
+ install -Dm755 "target/release/${pkgname}" "${pkgdir}/usr/bin/${pkgname}"
+ install -Dm644 LICENSE.md "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+
+}