summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Peukert2021-12-22 01:37:39 +0100
committerDaniel Peukert2021-12-22 01:37:39 +0100
commit07c1b3f2d19b1c7bca6d830ef0d3e0e85ddedb41 (patch)
tree2f744703f25e25150e8b144941f1185e9b268401
parentff3a48b4c629987e3f6695aadb644bb677b9b908 (diff)
downloadaur-07c1b3f2d19b1c7bca6d830ef0d3e0e85ddedb41.tar.gz
Fix failing Clippy tests for spot-client
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD17
-rw-r--r--clippy.diff10
3 files changed, 27 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b030c672fa8a..07fbd784fe37 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = spot-client-git
pkgdesc = Gtk/Rust native Spotify client - git version
- pkgver = 0.2.0.r14.g2a591fe
+ pkgver = 0.2.2.r36.g899a46b
pkgrel = 1
url = https://github.com/xou816/spot
arch = x86_64
@@ -28,6 +28,8 @@ pkgbase = spot-client-git
provides = spot-client
conflicts = spot-client
source = spot-client-git::git+https://github.com/xou816/spot
+ source = clippy.diff
sha512sums = SKIP
+ sha512sums = 8051c21a00c981eef8f0b08f30b369f28cd08d9d8d13b9f05df61b8365fc8ea91534aea7f21fcad6f14b41577fdfc9eaaf64dbd720d051e302fc7222d8aaf599
pkgname = spot-client-git
diff --git a/PKGBUILD b/PKGBUILD
index 19d38302b8a7..ebc2b0d518ef 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: NicoHood <archlinux {cat} nicohood {dog} de>
_projectname='spot'
pkgname="$_projectname-client-git"
-pkgver='0.2.0.r14.g2a591fe'
+pkgver='0.2.2.r36.g899a46b'
pkgrel='1'
pkgdesc='Gtk/Rust native Spotify client - git version'
arch=('x86_64' 'i686' 'arm' 'armv6h' 'armv7h' 'aarch64')
@@ -14,12 +14,23 @@ makedepends=('cargo' 'git' 'meson>=0.50.0')
checkdepends=('appstream-glib')
provides=("$_projectname-client")
conflicts=("$_projectname-client")
-source=("$pkgname::git+$url")
-sha512sums=('SKIP')
+source=(
+ "$pkgname::git+$url"
+ 'clippy.diff'
+)
+sha512sums=('SKIP'
+ '8051c21a00c981eef8f0b08f30b369f28cd08d9d8d13b9f05df61b8365fc8ea91534aea7f21fcad6f14b41577fdfc9eaaf64dbd720d051e302fc7222d8aaf599')
_sourcedirectory="$pkgname"
_builddirectory='build'
+prepare() {
+ cd "$srcdir/$_sourcedirectory/"
+
+ # Until they're fixed upstream, ignore some newly thrown errors from clippy 1.57
+ patch --forward -p1 < "$srcdir/clippy.diff"
+}
+
pkgver() {
cd "$srcdir/$_sourcedirectory/"
git describe --long --tags | sed -e 's/^v//' -e 's/-\([^-]*-g[^-]*\)$/-r\1/' -e 's/-/./g'
diff --git a/clippy.diff b/clippy.diff
new file mode 100644
index 000000000000..26b403fcef07
--- /dev/null
+++ b/clippy.diff
@@ -0,0 +1,10 @@
+diff --git a/build-aux/clippy.sh b/build-aux/clippy.sh
+index f60004b..22bdf6a 100644
+--- a/build-aux/clippy.sh
++++ b/build-aux/clippy.sh
+@@ -8,4 +8,4 @@ if [[ $OFFLINE = "true" ]]; then
+ export CARGO_HOME="$SRC"/cargo
+ fi
+
+-cargo clippy --manifest-path "$SRC"/Cargo.toml -- -D warnings -A clippy::module_inception -A clippy::new_without_default
++cargo clippy --manifest-path "$SRC"/Cargo.toml -- -D warnings -A clippy::module_inception -A clippy::new_without_default -A dead-code -A clippy::large-enum-variant -A clippy::redundant-closure -A clippy::derivable-impls