summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarcell Meszaros2022-06-27 22:35:59 +0200
committerMarcell Meszaros2022-06-27 22:35:59 +0200
commit07deed533c4bde8fb7958f601e3f77ec72387e87 (patch)
tree4cbf59b8d2e91b47aec879c0481b520eb31828d0
parent67bef0b4fc9948a713aa41111060adb4ec7595d1 (diff)
downloadaur-07deed533c4bde8fb7958f601e3f77ec72387e87.tar.gz
2.6.1-5: REMOVING THIS INSECURE MODULE. Deprecated since 2013.
-rw-r--r--.SRCINFO14
-rw-r--r--0001-replaced-time.clock-with-time.process_time-time-cloc.patch28
-rw-r--r--PKGBUILD33
3 files changed, 6 insertions, 69 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bbc28f22c2c8..cc6812ae12ef 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,11 @@
pkgbase = python-pycrypto
- pkgdesc = Cryptographic primitives and algorithms for Python
+ pkgdesc = DEPRECATED and insecure since 2013, so this is an empty dummy. Use Arch/community/python-pycryptodome.
pkgver = 2.6.1
- pkgrel = 4
- url = https://pypi.python.org/pypi/pycrypto
+ pkgrel = 5
+ url = https://github.com/pycrypto/pycrypto/blob/master/README.md
arch = any
license = Public domain
- makedepends = python-setuptools
- depends = python
- depends = python-flask
provides = python-crypto
conflicts = python-crypto
- conflicts = python-pycryptodome
- source = https://files.pythonhosted.org/packages/60/db/645aa9af249f059cc3a368b118de33889219e0362141e75d4eaf6f80f163/pycrypto-2.6.1.tar.gz
- source = 0001-replaced-time.clock-with-time.process_time-time-cloc.patch
- sha512sums = 20a4aed4dac4e9e61d773ebc1d48ea577e9870c33f396be53d075a9bf8487d93e75e200179882d81e452efd0f6751789bac434f6f431b3e7c1c8ef9dba392847
- sha512sums = 9a8c9812b3a13701571cb9cebb2fd755be7206f4045cbec76375259b716c2769dd25996cd8af89248cf7d9de0b088193a245442169c0c645ccd6083b529e3e50
pkgname = python-pycrypto
diff --git a/0001-replaced-time.clock-with-time.process_time-time-cloc.patch b/0001-replaced-time.clock-with-time.process_time-time-cloc.patch
deleted file mode 100644
index bd203159ebd8..000000000000
--- a/0001-replaced-time.clock-with-time.process_time-time-cloc.patch
+++ /dev/null
@@ -1,28 +0,0 @@
-From 6d41ad025331afce9e495d7be3205730ddfa8f07 Mon Sep 17 00:00:00 2001
-From: Fabian Topfstedt <topfstedt@schneevonmorgen.com>
-Date: Mon, 18 Nov 2019 22:19:35 +0100
-Subject: [PATCH] replaced time.clock with time.process_time (time clock was
- flagged as deprecated in Python 3.3 and got removed in Python 3.8)
-
----
- lib/Crypto/Random/_UserFriendlyRNG.py | 4 ++--
- 1 file changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/lib/Crypto/Random/_UserFriendlyRNG.py b/lib/Crypto/Random/_UserFriendlyRNG.py
-index 957e006..f389cfc 100644
---- a/lib/Crypto/Random/_UserFriendlyRNG.py
-+++ b/lib/Crypto/Random/_UserFriendlyRNG.py
-@@ -73,8 +73,8 @@ class _EntropyCollector(object):
- t = time.time()
- self._time_es.feed(struct.pack("@I", int(2**30 * (t - floor(t)))))
-
-- # Add the fractional part of time.clock()
-- t = time.clock()
-+ # Add the fractional part of time.process_time()
-+ t = time.process_time()
- self._clock_es.feed(struct.pack("@I", int(2**30 * (t - floor(t)))))
-
-
---
-2.27.0
-
diff --git a/PKGBUILD b/PKGBUILD
index 16fb9f0db49a..0ec31edf7b36 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,39 +5,12 @@
pkgname='python-pycrypto'
_pkgname='pycrypto'
pkgver=2.6.1
-pkgrel=4
-pkgdesc='Cryptographic primitives and algorithms for Python'
+pkgrel=5
+pkgdesc='DEPRECATED and insecure since 2013, so this is an empty dummy. Use Arch/community/python-pycryptodome.'
arch=('any')
-url='https://pypi.python.org/pypi/pycrypto'
+url='https://github.com/pycrypto/pycrypto/blob/master/README.md'
license=('Public domain')
-depends=(
- 'python'
- 'python-flask'
-)
-makedepends=('python-setuptools')
provides=('python-crypto')
conflicts=(
'python-crypto'
- 'python-pycryptodome'
-)
-source=(
- "https://files.pythonhosted.org/packages/60/db/645aa9af249f059cc3a368b118de33889219e0362141e75d4eaf6f80f163/pycrypto-${pkgver}.tar.gz"
- 0001-replaced-time.clock-with-time.process_time-time-cloc.patch
)
-sha512sums=('20a4aed4dac4e9e61d773ebc1d48ea577e9870c33f396be53d075a9bf8487d93e75e200179882d81e452efd0f6751789bac434f6f431b3e7c1c8ef9dba392847'
- '9a8c9812b3a13701571cb9cebb2fd755be7206f4045cbec76375259b716c2769dd25996cd8af89248cf7d9de0b088193a245442169c0c645ccd6083b529e3e50')
-
-build() {
- cd "$_pkgname-$pkgver"
- python setup.py build
-}
-
-prepare() {
- cd "$_pkgname-$pkgver"
- patch -p1 < ../0001-replaced-time.clock-with-time.process_time-time-cloc.patch
-}
-
-package() {
- cd "$_pkgname-$pkgver"
- python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
-}