summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorthe_lf2016-08-18 23:49:00 -0600
committerthe_lf2016-08-18 23:49:00 -0600
commit081c885dfe303a7545f270bed9f40a5c9cda332c (patch)
treeaa5d1ee34b72ca1f60a8482e400071dbdd6bb2bf
parent10b2d314447914679e11c8849cefbbc165d5b2f5 (diff)
downloadaur-081c885dfe303a7545f270bed9f40a5c9cda332c.tar.gz
Fix build, improve gitignore, space indentation
Author of lighthouse: why the hell did you remove the default target in your makefile?!
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD22
2 files changed, 13 insertions, 11 deletions
diff --git a/.gitignore b/.gitignore
index cadae6b64507..293360cb8580 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,2 +1,4 @@
lighthouse
src
+*.pkg*
+pkg
diff --git a/PKGBUILD b/PKGBUILD
index c8afc24a0222..50390104129e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=lighthouse-git
pkgrel=1
pkgdesc='A simple scriptable popup dialog to run on X'
-pkgver=r173.a9b41fa
+pkgver=r269.069b07b
arch=('any') # I haven't tested it on ARM but it most likely works
url='https://github.com/emgram769/lighthouse'
license=('MIT')
@@ -17,20 +17,20 @@ provides=('lighthouse')
conflicts=('lighthouse') # in case someone makes a stable package
pkgver() {
- cd "lighthouse"
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ cd "lighthouse"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
build() {
- cd "${srcdir}/lighthouse"
- make
+ cd "${srcdir}/lighthouse"
+ make lighthouse
}
package() {
- cd "${srcdir}/lighthouse"
- mkdir -p ${pkgdir}/usr/{bin,share/lighthouse}
- cp lighthouse "${pkgdir}/usr/bin"
- chmod +x "${pkgdir}/usr/bin/lighthouse"
- cp -ir config/lighthouse/* "${pkgdir}/usr/share/lighthouse"
- chmod +x ${pkgdir}/usr/share/lighthouse/cmd{,.py}
+ cd "${srcdir}/lighthouse"
+ mkdir -p ${pkgdir}/usr/{bin,share/lighthouse}
+ cp lighthouse "${pkgdir}/usr/bin"
+ chmod +x "${pkgdir}/usr/bin/lighthouse"
+ cp -ir config/lighthouse/* "${pkgdir}/usr/share/lighthouse"
+ chmod +x ${pkgdir}/usr/share/lighthouse/cmd{,.py}
}