summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorThomas Haider2015-06-18 19:05:17 +0200
committerThomas Haider2015-06-18 19:05:17 +0200
commit0847ca208c622b1ed1c16574f3af0008ef788433 (patch)
tree179ffc21efc49e5f94630dfc4bcdc067781282e2
downloadaur-0847ca208c622b1ed1c16574f3af0008ef788433.tar.gz
import from old AUR
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD20
-rw-r--r--ttf-comic-neue.install15
3 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e4ccc090258f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = ttf-comic-neue
+ pkgdesc = Comic Neue aspires to be the casual script choice for everyone including the typographically savvy.
+ pkgver = 2.2
+ pkgrel = 1
+ url = http://comicneue.com
+ install = ttf-comic-neue.install
+ arch = any
+ license = custom:OFL
+ depends = fontconfig
+ source = http://comicneue.com/comic-neue-2.2.zip
+ source = ttf-comic-neue.install
+ sha256sums = d67c7de093b3555a525a29db1999b7759723208f514f5fca117201d63b94b5b6
+ sha256sums = 2459fa08887f819049afac36d7e7e23d7b9f58eb39c35ce02b17ce1096885c16
+
+pkgname = ttf-comic-neue
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4dfadc1955c8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Maintainer: Thomas Haider <t.haider@deprecate.de>
+
+pkgname=ttf-comic-neue
+pkgver=2.2
+pkgrel=1
+pkgdesc="Comic Neue aspires to be the casual script choice for everyone including the typographically savvy."
+arch=('any')
+license=('custom:OFL')
+url="http://comicneue.com"
+depends=('fontconfig')
+install=ttf-comic-neue.install
+source=("http://comicneue.com/comic-neue-${pkgver}.zip" ttf-comic-neue.install)
+sha256sums=('d67c7de093b3555a525a29db1999b7759723208f514f5fca117201d63b94b5b6'
+ '2459fa08887f819049afac36d7e7e23d7b9f58eb39c35ce02b17ce1096885c16')
+
+package() {
+ install -D -m644 comic-neue-${pkgver}/SIL-License.txt "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -d "${pkgdir}/usr/share/fonts/OTF"
+ install -m644 comic-neue-${pkgver}/OTF/*.otf "${pkgdir}/usr/share/fonts/OTF/"
+}
diff --git a/ttf-comic-neue.install b/ttf-comic-neue.install
new file mode 100644
index 000000000000..309a51b29340
--- /dev/null
+++ b/ttf-comic-neue.install
@@ -0,0 +1,15 @@
+post_install() {
+ post_remove $1
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+post_remove() {
+ echo -n "==> Rebuilding font cache... "
+ fc-cache -s &> /dev/null
+ mkfontscale /usr/share/fonts/OTF
+ mkfontdir /usr/share/fonts/OTF
+ echo "done"
+}