summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexei Colin2017-09-24 19:04:28 -0400
committerAlexei Colin2017-09-24 19:04:28 -0400
commit08671141934076962524373ffb6175e8c107fbba (patch)
tree6e0410816c8e734c9bbce8c8d6fd0038ea0d7d7e
parent43531c87ab45fb249b9e476c565515857cc999bd (diff)
downloadaur-08671141934076962524373ffb6175e8c107fbba.tar.gz
update upstream URL to new repo
-rw-r--r--PKGBUILD9
1 files changed, 8 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d22d59ca361b..a757fc7c2c54 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -16,7 +16,7 @@ license=('MIT')
install=taskd.install
-source=("${pkgname}::git+https://git.tasktools.org/scm/tm/taskd.git#branch=${_branch}"
+source=("${pkgname}::git+https://git.tasktools.org/TM/taskd.git#branch=${_branch}"
'taskd.conf'
'taskd.notes'
'taskd.service')
@@ -37,6 +37,13 @@ pkgver() {
git describe --long origin/$_branch | sed 's/^s//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
+prepare() {
+ cd ${srcdir}/${pkgname}
+ git submodule init
+ git config submodule.libshared.url src/libshared
+ git submodule update
+}
+
build() {
cd "${srcdir}/${pkgname}"