summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCôme Chilliet2020-08-20 23:59:12 +0200
committerCôme Chilliet2020-08-20 23:59:12 +0200
commit0876ca7db11084f15eadbf1617ece7d9eb701a6a (patch)
tree4f0ff9e9310a22bce46fed930893fd204c087bec
parente08b474a8ccc318c3bdf85f40d6766d60e170714 (diff)
downloadaur-0876ca7db11084f15eadbf1617ece7d9eb701a6a.tar.gz
Update by franck.stauffer
-rw-r--r--.SRCINFO37
-rw-r--r--PKGBUILD46
2 files changed, 37 insertions, 46 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3c22a8383f00..507307785de4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,36 +1,27 @@
pkgbase = solarus
pkgdesc = A lightweight, free and open-source game engine for Action-RPGs
- pkgver = 1.6.2
+ pkgver = 1.6.4
pkgrel = 1
url = http://www.solarus-games.org/
arch = i686
arch = x86_64
- license = GPL
+ license = GPL3
makedepends = cmake
- depends = luajit
- depends = sdl2_image
- depends = sdl2_ttf
- depends = physfs
- depends = openal
+ depends = glm
+ depends = hicolor-icon-theme
+ depends = libmodplug>=0.8.8.4
depends = libvorbis
- depends = libmodplug
- depends = qt5-tools
+ depends = luajit>=2.0
+ depends = openal
+ depends = physfs
depends = qt5-base
- depends = libglvnd
- optdepends = zsxd
- optdepends = zsdx
- optdepends = zelda-roth-se
- provides = solarus-engine
- conflicts = zsdxdemo-en
- conflicts = zsdxdemo-de
- conflicts = zsdxdemo-fr
+ depends = sdl2>=2.0.6
+ depends = sdl2_image
+ depends = sdl2_ttf
conflicts = solarus-git
- replaces = zsdxdemo-en
- replaces = zsdxdemo-de
- replaces = zsdxdemo-fr
- replaces = solarus-git
- source = https://gitlab.com/solarus-games/solarus/-/archive/v1.6.2/solarus-v1.6.2.tar.gz
- md5sums = f5ea8ccddb3d26136b5de51e255e991f
+ conflicts = solarus-run
+ source = https://gitlab.com/solarus-games/solarus/-/archive/v1.6.4/solarus-v1.6.4.tar.gz
+ b2sums = fdf9b6703af8424b4731b25b307dcc7a0966cbf89a0bf043bcfb6745d0c6e8aa1fee026f206a41ebf6c8d54b23a9a3816a6c2d7ae004c9db7c436425a94aa7d3
pkgname = solarus
diff --git a/PKGBUILD b/PKGBUILD
index e2d768af651e..5aebe9d0b302 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,40 +4,40 @@
# Contributor: BenObiWan <benobiwan @t gmail dot com>
# Contributor: Huulivoide
# Contributor: Fernando Carmona Varo <ferkiwi @t gmail dot com>
+# Contributor: Franck Stauffer <franck.stauffer@monaco.mc>
pkgname=solarus
-pkgver=1.6.2
+pkgver=1.6.4
pkgrel=1
-epoch=
pkgdesc="A lightweight, free and open-source game engine for Action-RPGs"
arch=('i686' 'x86_64')
url="http://www.solarus-games.org/"
-license=('GPL')
-groups=()
-depends=('luajit' 'sdl2_image' 'sdl2_ttf' 'physfs' 'openal' 'libvorbis' 'libmodplug' 'qt5-tools' 'qt5-base' 'libglvnd')
+license=('GPL3')
+depends=('glm'
+ 'hicolor-icon-theme'
+ 'libmodplug>=0.8.8.4'
+ 'libvorbis'
+ 'luajit>=2.0'
+ 'openal'
+ 'physfs'
+ 'qt5-base'
+ 'sdl2>=2.0.6'
+ 'sdl2_image'
+ 'sdl2_ttf')
makedepends=('cmake')
-checkdepends=()
-optdepends=('zsxd' 'zsdx' 'zelda-roth-se')
-provides=('solarus-engine')
-conflicts=('zsdxdemo-en' 'zsdxdemo-de' 'zsdxdemo-fr' 'solarus-git')
-replaces=('zsdxdemo-en' 'zsdxdemo-de' 'zsdxdemo-fr' 'solarus-git')
-backup=()
-options=()
-install=
-changelog=
+conflicts=('solarus-git' 'solarus-run')
source=("https://gitlab.com/solarus-games/${pkgname}/-/archive/v${pkgver}/${pkgname}-v${pkgver}.tar.gz")
-noextract=()
-md5sums=('f5ea8ccddb3d26136b5de51e255e991f')
+b2sums=('fdf9b6703af8424b4731b25b307dcc7a0966cbf89a0bf043bcfb6745d0c6e8aa1fee026f206a41ebf6c8d54b23a9a3816a6c2d7ae004c9db7c436425a94aa7d3')
-build() {
- cd "${srcdir}/${pkgname}-v${pkgver}"
+prepare() {
+ cd "$pkgname-v$pkgver"
+ cmake -Wno-dev -DSOLARUS_TESTS=OFF -DCMAKE_INSTALL_PREFIX="/usr" -DCMAKE_BUILD_TYPE=Release .
+}
- cmake -D CMAKE_INSTALL_PREFIX="/usr" -D CMAKE_BUILD_TYPE=Release -D DEFAULT_QUEST=/usr/share/solarus/zsdx .
- make
+build() {
+ make -C "$pkgname-v$pkgver" ${MAKEFLAGS}
}
package() {
- cd "${srcdir}/${pkgname}-v${pkgver}"
- make DESTDIR="${pkgdir}/" PREFIX="/usr" install
+ make -C "$pkgname-v$pkgver" DESTDIR="${pkgdir}/" install
}
-