summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFadeMind2015-07-30 13:12:59 +0200
committerFadeMind2015-07-30 13:12:59 +0200
commit088fadb62dcfb7812a97baed56806a4dd5eb3c01 (patch)
tree1bec8f873cab6cc7f8a6a7a0d213eacb52231fcd
parentaf0a12a3074b83ad1966cc9cef2a64d5c8fab569 (diff)
downloadaur-088fadb62dcfb7812a97baed56806a4dd5eb3c01.tar.gz
20150730-1
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD19
2 files changed, 17 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 17e96d34c565..8044b1f608e1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,20 @@
pkgbase = zephyrflattr-bundle
- pkgdesc = Bundle a clean and flat theme for KDE4
- pkgver = 20150328
+ pkgdesc = Bundle a clean and flat theme for KDE4.
+ pkgver = 20150730
pkgrel = 1
url = https://github.com/FadeMind/zephyrflattr
arch = any
license = CCPL:by-sa
depends = qtcurve-qt4
+ depends = qtcurve-qt5
+ depends = qtcurve-kde4
+ depends = qtcurve-gtk2
+ depends = qtcurve-utils
depends = kdebase-workspace
optdepends = faenzaflattr-zephyr-icon-theme: recommended icon theme
optdepends = breeze-obsidian-cursor-theme: recommended cursor theme
- source = zephyrflattr-bundle-20150328.tar.gz::https://github.com/FadeMind/zephyrflattr/archive/8af8acb0889692f2a5f5c08398f3ca6b53452360.tar.gz
- sha256sums = 908c97ee297525bf192edff4aab085f3d6438646156fa663155640d24a343d1c
+ source = zephyrflattr-bundle-20150730.tar.gz::https://github.com/FadeMind/zephyrflattr/archive/68f43f51bd9da40e8fcf57ac1f631b65ecfd156b.tar.gz
+ sha256sums = 0e645ca9a21ae53c18b093011cdf747326f5fe9f385b361bf6965f8246e6d7ef
pkgname = zephyrflattr-bundle
diff --git a/PKGBUILD b/PKGBUILD
index 195b63240b5c..7b6910325d86 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,25 @@
# Maintainer: FadeMind <fademind@gmail.com>
-_git=8af8acb0889692f2a5f5c08398f3ca6b53452360
-_basename=zephyrflattr
-pkgname=${_basename}-bundle
-pkgver=20150328
+_git=68f43f51bd9da40e8fcf57ac1f631b65ecfd156b
+_pkgname=zephyrflattr
+pkgname=${_pkgname}-bundle
+pkgver=20150730
pkgrel=1
-pkgdesc="Bundle a clean and flat theme for KDE4"
+pkgdesc="Bundle a clean and flat theme for KDE4."
arch=('any')
-url="https://github.com/FadeMind/${_basename}"
+url="https://github.com/FadeMind/${_pkgname}"
license=('CCPL:by-sa')
-depends=('qtcurve-qt4' 'kdebase-workspace')
+depends=(qtcurve-{qt4,qt5,kde4,gtk2,utils} kdebase-workspace)
optdepends=('faenzaflattr-zephyr-icon-theme: recommended icon theme'
'breeze-obsidian-cursor-theme: recommended cursor theme')
source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/${_git}.tar.gz")
-sha256sums=('908c97ee297525bf192edff4aab085f3d6438646156fa663155640d24a343d1c')
+sha256sums=('0e645ca9a21ae53c18b093011cdf747326f5fe9f385b361bf6965f8246e6d7ef')
package() {
- cd ${srcdir}/${_basename}-${_git}
+ cd ${srcdir}/${_pkgname}-${_git}
find *.colors -type f -exec install -Dm644 '{}' "${pkgdir}/usr/share/apps/color-schemes/{}" \;
find ZephyrFlattr/* -type f -exec install -Dm 644 '{}' "${pkgdir}/usr/share/apps/desktoptheme/{}" \;
find ZephyrFlattr.qtcurve -type f -exec install -Dm644 '{}' "${pkgdir}/usr/share/apps/QtCurve/{}" \;
- install -Dm644 ${srcdir}/${_basename}-${_git}/LICENSE ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
find ${pkgdir}/usr -type f -exec chmod 644 {} \;
find ${pkgdir}/usr -type d -exec chmod 755 {} \;
}