summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDanManN2018-12-05 21:52:45 -0500
committerDanManN2018-12-05 21:52:45 -0500
commit0895334a29dc6d4856b5022cdb72f73b345c5188 (patch)
tree5a9c80f6b4f7038eff3c99f9851ada39f579e496
downloadaur-0895334a29dc6d4856b5022cdb72f73b345c5188.tar.gz
a spacy thing
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD27
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9d1b63b51130
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = python-wasabi-git
+ pkgdesc = A lightweight console printing and formatting toolkit
+ pkgver = 0.0.10.r72.0363236
+ pkgrel = 1
+ url = https://github.com/ines/wasabi
+ arch = x86_64
+ license = MIT
+ makedepends = python-setuptools
+ depends = python
+ provides = python-wasabi
+ conflicts = python-wasabi
+ source = git+https://github.com/ines/wasabi.git
+ md5sums = SKIP
+
+pkgname = python-wasabi-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2a69c1a2003c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: DanManN <dnahimov@gmail.com>
+# Python package author: Ines Montani <ines@explosion.ai>
+pkgname=python-wasabi-git
+_origpkgname=wasabi
+pkgver=0.0.10.r72.0363236
+pkgrel=1
+pkgdesc="A lightweight console printing and formatting toolkit"
+arch=("x86_64")
+url="https://github.com/ines/wasabi"
+license=("MIT")
+depends=('python')
+makedepends=("python-setuptools")
+provides=('python-wasabi')
+conflicts=('python-wasabi')
+source=("git+https://github.com/ines/$_origpkgname.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$_origpkgname"
+ printf "%s.r%s.%s" "$(cat wasabi/about.py | grep -i version | grep -v '#' | cut -d '"' -f2 | head -n 1)" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "$_origpkgname"
+ python setup.py install --root="${pkgdir}/" --optimize=1
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}