summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDarren Ng2021-01-09 21:59:09 +0800
committerDarren Ng2021-01-09 21:59:09 +0800
commit0896ff55a065668e6ff8423ec9dde09e9c1331cd (patch)
tree41294f5bb12572c8aeb587cd6e900cebdefe7949
downloadaur-0896ff55a065668e6ff8423ec9dde09e9c1331cd.tar.gz
re-uploaded from buildroot-dummy
-rw-r--r--.SRCINFO46
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD67
3 files changed, 118 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8160e34cdd5b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,46 @@
+pkgbase = buildroot-meta
+ pkgdesc = dependency requirements for buildroot
+ pkgver = 2020.11.1
+ pkgrel = 1
+ url = https://buildroot.org/downloads/manual/manual.html#requirement
+ arch = any
+ license = GPL
+ depends = which
+ depends = sed
+ depends = make>=3.81
+ depends = binutils
+ depends = gcc>=4.8
+ depends = bash
+ depends = patch
+ depends = gzip
+ depends = bzip2
+ depends = perl>=5.8.7
+ depends = tar
+ depends = cpio
+ depends = unzip
+ depends = rsync
+ depends = file
+ depends = bc
+ depends = wget
+ optdepends = python
+ optdepends = ncurses: menuconfig & nconfig
+ optdepends = qt5-base: xconfig
+ optdepends = gtk2: gconfig
+ optdepends = glib2: gconfig
+ optdepends = libglade: gconfig
+ optdepends = breezy: bazaar
+ optdepends = cvs
+ optdepends = git
+ optdepends = mercurial
+ optdepends = rsync
+ optdepends = openssh: scp
+ optdepends = subversion
+ optdepends = asciidoc
+ optdepends = w3m
+ optdepends = python-argparse
+ optdepends = dblatex: pdf manual
+ optdepends = graphviz: graph-depends & <pkg>-graph-depends
+ optdepends = python-matplotlib: graph-build
+
+pkgname = buildroot-meta
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..c6a9b954b0ed
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+*
+
+!.gitignore
+!PKGBUILD
+!.SRCINFO
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3f9bf9a12c49
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,67 @@
+# Maintainer: Darren Ng <$(base64 --decode <<<'ZGFycmVuMTk5NzA4MTBAZ21haWwuY29tCg==')>
+
+pkgname=buildroot-meta
+pkgver=2020.11.1
+pkgrel=1
+pkgdesc="dependency requirements for buildroot"
+arch=('any')
+url="https://buildroot.org/downloads/manual/manual.html#requirement"
+license=('GPL')
+depends=(
+ 'which'
+ 'sed'
+ 'make>=3.81'
+ 'binutils'
+ 'gcc>=4.8'
+ 'bash'
+ 'patch'
+ 'gzip'
+ 'bzip2'
+ 'perl>=5.8.7'
+ 'tar'
+ 'cpio'
+ 'unzip'
+ 'rsync'
+ 'file'
+ 'bc'
+ 'wget'
+)
+optdepends=(
+
+ # Recommended dependencies
+ 'python'
+
+ # Configuration interface dependencies
+ # output/build/buildroot-config/
+ 'ncurses: menuconfig & nconfig'
+ 'qt5-base: xconfig'
+ 'gtk2: gconfig'
+ 'glib2: gconfig'
+ 'libglade: gconfig'
+
+ # Source fetching tools
+ 'breezy: bazaar'
+ 'cvs'
+ 'git'
+ 'mercurial'
+ 'rsync'
+ 'openssh: scp'
+ 'subversion'
+
+ # Java-related packages
+
+ # Documentation generation tools
+ 'asciidoc'
+ 'w3m'
+ 'python-argparse'
+ 'dblatex: pdf manual'
+
+ # Graph generation tools
+ 'graphviz: graph-depends & <pkg>-graph-depends'
+ 'python-matplotlib: graph-build'
+
+)
+# provides=("${pkgname%-meta}")
+# conflicts=("${pkgname%-meta}")
+# source=('SKIP')
+# md5sums=('SKIP')