summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJonah Bernhard2016-04-21 12:02:19 -0400
committerJonah Bernhard2016-04-21 12:02:19 -0400
commit08a176422aa95d6ba6d53cdac30dd00578bcbf60 (patch)
treeab43e2c66de5f6f9d46621e4b7982d3a64877a11
parent628cf7a28f44e2b419dde72756e2bc705630550d (diff)
downloadaur-08a176422aa95d6ba6d53cdac30dd00578bcbf60.tar.gz
Bump svn version and remove patch.
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD11
-rw-r--r--mlbviewer-60fps.patch53
3 files changed, 7 insertions, 61 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2070bb90f22e..cacd029d264b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,8 @@
+# Generated by mksrcinfo v8
+# Thu Apr 21 16:02:07 UTC 2016
pkgbase = mlbviewer-svn
pkgdesc = A collection of tools to view and listen to streaming baseball games from MLB.TV.
- pkgver = r662
+ pkgver = r663
pkgrel = 1
url = http://sourceforge.net/projects/mlbviewer
install = mlbviewer.install
diff --git a/PKGBUILD b/PKGBUILD
index c8538710f669..e0981c98f0b9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Jonah Bernhard <jonah.bernhard at gmail dot com>
pkgname=mlbviewer-svn
-pkgver=r662
+pkgver=r663
_pkgname=${pkgname%-svn}
-pkgrel=2
+pkgrel=1
pkgdesc="A collection of tools to view and listen to streaming baseball games from MLB.TV."
arch=('i686' 'x86_64')
url="http://sourceforge.net/projects/mlbviewer"
@@ -15,9 +15,8 @@ conflicts=('mlbviewer')
provides=('mlbviewer')
install="${_pkgname}.install"
source=("${pkgname}::svn://svn.code.sf.net/p/mlbviewer/code/trunk"
- "mlbhls::git+https://github.com/tonycpsu/mlbtv-hls-nexdef#branch=experimental"
- "mlbviewer-60fps.patch")
-sha1sums=('SKIP' 'SKIP' 'f3c3c29e1421f77fb047da9b43de84b756cb1009')
+ "mlbhls::git+https://github.com/tonycpsu/mlbtv-hls-nexdef#branch=experimental")
+sha1sums=('SKIP' 'SKIP')
pkgver() {
@@ -31,8 +30,6 @@ build() {
cd ${srcdir}/${pkgname}
sed -i 's:#!/usr/bin/env python:#!/usr/bin/env python2:' *.py
- patch -p0 < $srcdir/mlbviewer-60fps.patch
-
# build mlbhls for nexdef
cd ${srcdir}/mlbhls
make
diff --git a/mlbviewer-60fps.patch b/mlbviewer-60fps.patch
deleted file mode 100644
index 5be4017ceb6b..000000000000
--- a/mlbviewer-60fps.patch
+++ /dev/null
@@ -1,53 +0,0 @@
-Index: MLBviewer/mlbConfig.py
-===================================================================
---- MLBviewer/mlbConfig.py (revision 662)
-+++ MLBviewer/mlbConfig.py (working copy)
-@@ -109,7 +109,7 @@
- 'highlight_division',
- 'gameday_audio',
- 'international',
-- 'curses_debug', 'use_wired_web' ):
-+ 'curses_debug', 'use_wired_web', 'use_wired_web_60' ):
- if val.isdigit():
- self.data[key] = bool(int(val))
- else:
-Index: MLBviewer/mlbConstants.py
-===================================================================
---- MLBviewer/mlbConstants.py (revision 662)
-+++ MLBviewer/mlbConstants.py (working copy)
-@@ -196,7 +196,7 @@
-
- STREAM_SPEEDS = ( '300', '500', '1200', '1800', '2500' )
-
--NEXDEF_SPEEDS = ( '128', '500', '800', '1200', '1800', '2400', '3000', '4500' )
-+NEXDEF_SPEEDS = ( '128', '500', '800', '1200', '1800', '2400', '3000', '4500', '5000' )
-
- DEFAULT_SPEED = '1200'
-
-Index: MLBviewer/mlbMediaStream.py
-===================================================================
---- MLBviewer/mlbMediaStream.py (revision 662)
-+++ MLBviewer/mlbMediaStream.py (working copy)
-@@ -22,6 +22,7 @@
- import os
- import subprocess
- import select
-+import base64
-
- from copy import deepcopy
- from xml.dom.minidom import parse
-@@ -175,6 +176,14 @@
- self.updateSession(reply)
- content_list = self.parseMediaReply(reply)
- game_url = self.requestSpecificMedia()
-+ if self.cfg.get('use_nexdef') and self.cfg.get('use_wired_web_60'):
-+ # replace default playlist with 60 fps version in base64 url
-+ game_url = base64.encodestring(
-+ base64.decodestring(game_url).replace(
-+ 'master_wired_web.m3u8',
-+ 'master_wired60.m3u8'
-+ )
-+ ).replace('\n', '')
- return game_url
-
-