summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSlashbunny2020-05-21 21:36:04 -0400
committerSlashbunny2020-05-21 21:36:04 -0400
commit08bc0835085e4a294bd5a1dcd6b490dfed8245a1 (patch)
tree49b8548484b0ca26f1575e104281841f4f73d18b
parent9bf401b03ebc1e23480ab857ee43df5d55df32cd (diff)
downloadaur-08bc0835085e4a294bd5a1dcd6b490dfed8245a1.tar.gz
Update to 3.2
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD18
2 files changed, 15 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1da6caa76cbb..1a9c76b97e63 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = ezquake
pkgdesc = One of the most Popular QuakeWorld clients for Linux/BSD/OSX/Win32. You need the retail pak files to play.
- pkgver = 3.1
+ pkgver = 3.2
pkgrel = 1
url = http://ezquake.sourceforge.net/
install = ezquake.install
@@ -20,14 +20,14 @@ pkgbase = ezquake
provides = fuhquake
conflicts = ezquake-git
conflicts = fuhquake
- noextract = ezquake3.1-linux64-full.tar.gz
- source = https://github.com/ezQuake/ezquake-source/releases/download/3.1/ezquake-source-3.1.tar.gz
- source = https://github.com/ezQuake/ezquake-source/releases/download/3.1/ezquake3.1-linux64-full.tar.gz
+ noextract = ezquake-ubuntu-full-3.2.tar.gz
+ source = https://github.com/ezQuake/ezquake-source/archive/3.2.tar.gz
+ source = https://github.com/ezQuake/ezquake-source/releases/download/3.2/ezquake-ubuntu-full-3.2.tar.gz
source = ezquake.launcher
source = ezquake.desktop
source = ezquake.ico
- sha256sums = 3465ba1720173b304ea29a557cee8a165f6d51eec680da0caac9d24f88aa928e
- sha256sums = 9c3a1ba6e9ebebd05e7e31f126d984d9e9b62803c4869c8ad5e2be1637437690
+ sha256sums = 801151d540706106cbd26da7266aa5e330842b8cccbc5acd4bc8d5a73db3515d
+ sha256sums = 6977480a374e531341dec82ccabf3f1443c674959f0e959b7a4c9a63cc2e06c5
sha256sums = aa59da4a296a43af8ea8c5670cef5980a15407124b3e53f3cf805ceb6126e6ed
sha256sums = e92b9cdeac5eadced50a6167eb53b1343b0772d3bf8afa310eb281b88bf7e677
sha256sums = 2a6a5484ddb4cfaf8518b51df39ffd1fa8ce768402eab6401415bececb8e8ab2
diff --git a/PKGBUILD b/PKGBUILD
index eff4efd6eb9f..51eb48ebcd33 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Slash <demodevil5[at]yahoo[dot]com>
pkgname=ezquake
-pkgver=3.1
+pkgver=3.2
pkgrel=1
pkgdesc="One of the most Popular QuakeWorld clients for Linux/BSD/OSX/Win32. You need the retail pak files to play."
url="http://ezquake.sourceforge.net/"
@@ -12,18 +12,18 @@ conflicts=('ezquake-git' 'fuhquake')
provides=('quake' 'fuhquake')
arch=('x86_64')
install=ezquake.install
-source=("https://github.com/ezQuake/ezquake-source/releases/download/${pkgver}/ezquake-source-${pkgver}.tar.gz"
-"https://github.com/ezQuake/ezquake-source/releases/download/${pkgver}/ezquake${pkgver}-linux64-full.tar.gz"
+source=("https://github.com/ezQuake/ezquake-source/archive/${pkgver}.tar.gz"
+"https://github.com/ezQuake/ezquake-source/releases/download/${pkgver}/ezquake-ubuntu-full-${pkgver}.tar.gz"
'ezquake.launcher' 'ezquake.desktop' 'ezquake.ico')
-noextract=("ezquake${pkgver}-linux64-full.tar.gz")
-sha256sums=('3465ba1720173b304ea29a557cee8a165f6d51eec680da0caac9d24f88aa928e'
- '9c3a1ba6e9ebebd05e7e31f126d984d9e9b62803c4869c8ad5e2be1637437690'
+noextract=("ezquake-ubuntu-full-${pkgver}.tar.gz")
+sha256sums=('801151d540706106cbd26da7266aa5e330842b8cccbc5acd4bc8d5a73db3515d'
+ '6977480a374e531341dec82ccabf3f1443c674959f0e959b7a4c9a63cc2e06c5'
'aa59da4a296a43af8ea8c5670cef5980a15407124b3e53f3cf805ceb6126e6ed'
'e92b9cdeac5eadced50a6167eb53b1343b0772d3bf8afa310eb281b88bf7e677'
'2a6a5484ddb4cfaf8518b51df39ffd1fa8ce768402eab6401415bececb8e8ab2')
build() {
- cd "${srcdir}"
+ cd "${srcdir}/ezquake-source-${pkgver}/"
# Compile ezquake
make
@@ -36,14 +36,14 @@ package() {
install -d "${pkgdir}/opt/quake"
# Unpack ezQuake assets package (base)
- bsdtar -x -o -C "${pkgdir}/opt/quake" -f "${srcdir}/ezquake${pkgver}-linux64-full.tar.gz"
+ bsdtar -x -o -C "${pkgdir}/opt/quake" -f "${srcdir}/ezquake-ubuntu-full-${pkgver}.tar.gz"
# Clean up permissions in assets package
find "${pkgdir}/opt/quake" -type d -exec chmod 0755 "{}" \;
find "${pkgdir}/opt/quake" -type f -exec chmod 0644 "{}" \;
# Overwrite packaged binary with compiled one
- mv -v "${srcdir}/ezquake-linux-x86_64" \
+ mv -v "${srcdir}/ezquake-source-${pkgver}/ezquake-linux-x86_64" \
"${pkgdir}/opt/quake/"
# Make id1 Directory for pak0.pak and pak1.pak files