summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPieter Goetschalckx2020-03-04 01:58:39 +0100
committerPieter Goetschalckx2020-03-04 01:58:39 +0100
commit08bcad791b9a627fbd298c49412a343a7d0efb5c (patch)
treeb60a9bf09e9af6e450e30b4d2a3657fd33ffdd7d
parent9943dbd26250082686604d936afce30105e1e314 (diff)
downloadaur-08bcad791b9a627fbd298c49412a343a7d0efb5c.tar.gz
v0.0.6
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD9
2 files changed, 8 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 20f50794b6ee..e8135099594d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,15 @@
pkgbase = fx_cast
pkgdesc = Implementation of the Chrome Sender API (Chromecast) within Firefox
- pkgver = 0.0.5
- pkgrel = 2
+ pkgver = 0.0.6
+ pkgrel = 1
url = https://hensm.github.io/fx_cast/
arch = x86_64
license = MIT
makedepends = npm
- depends = nodejs
conflicts = fx_cast-bin
options = !strip
- source = https://github.com/hensm/fx_cast/archive/v0.0.5.tar.gz
- sha256sums = 5636939846247bee0c7c14689a2daed717ac700f72d85e71ae152a5e44543ea4
+ source = https://github.com/hensm/fx_cast/archive/v0.0.6.tar.gz
+ sha256sums = b7044abfd46f9ccbe2a0a79632d5e0e10154a0cd23e4712f97efe58013dd7cdc
pkgname = fx_cast
diff --git a/PKGBUILD b/PKGBUILD
index abd45b1cea57..17579a5e80a5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,23 +2,22 @@
# Contributor: csicar
pkgname=fx_cast
-pkgver=0.0.5
-pkgrel=2
+pkgver=0.0.6
+pkgrel=1
pkgdesc="Implementation of the Chrome Sender API (Chromecast) within Firefox"
arch=('x86_64')
url="https://hensm.github.io/fx_cast/"
license=('MIT')
-depends=('nodejs')
makedepends=('npm')
conflicts=('fx_cast-bin')
options=('!strip')
source=("https://github.com/hensm/${pkgname}/archive/v${pkgver}.tar.gz")
-sha256sums=('5636939846247bee0c7c14689a2daed717ac700f72d85e71ae152a5e44543ea4')
+sha256sums=('b7044abfd46f9ccbe2a0a79632d5e0e10154a0cd23e4712f97efe58013dd7cdc')
build() {
cd "${pkgname}-${pkgver}"
- npm install
+ npm install --cache "${srcdir}/npm-cache"
npm run build:app
sed -i 's#"path":.*$#"path": "/usr/bin/fx_cast_bridge"#' dist/app/fx_cast_bridge.json
}