summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorOleksandr Natalenko2023-06-21 09:56:22 +0200
committerOleksandr Natalenko2023-06-21 09:56:22 +0200
commit08c7077a0de05c21a43e605b7192d75eabc5ac75 (patch)
tree72b50ed4d62594a861728828825c31b2b9fd0272
parente05f3367ab793fc7d2508ef654a2341849320d74 (diff)
downloadaur-08c7077a0de05c21a43e605b7192d75eabc5ac75.tar.gz
update to v23.01
Signed-off-by: Oleksandr Natalenko <oleksandr@natalenko.name>
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD10
-rw-r--r--meson.build25
3 files changed, 21 insertions, 24 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0cc622aeae3c..113e9250a64c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = 7-zip
pkgdesc = File archiver with a high compression ratio
- pkgver = 22.01
- pkgrel = 2
+ pkgver = 23.01
+ pkgrel = 1
url = https://7-zip.org
arch = x86_64
license = LGPL
@@ -9,9 +9,9 @@ pkgbase = 7-zip
license = custom:unRAR
makedepends = uasm
makedepends = meson
- source = https://7-zip.org/a/7z2201-src.tar.xz
+ source = https://7-zip.org/a/7z2301-src.tar.xz
source = meson.build
- sha256sums = 393098730c70042392af808917e765945dc2437dee7aae3cfcc4966eb920fbc5
- sha256sums = 8b47dd17a5094b487dc343f00113db3c08e94e929a494fbd582bd8c067e539e3
+ sha256sums = 356071007360e5a1824d9904993e8b2480b51b570e8c9faf7c0f58ebe4bf9f74
+ sha256sums = 211a57a476943e654de7408145b8d626a4dc242e74a3dcb8fc3afd0620792a03
pkgname = 7-zip
diff --git a/PKGBUILD b/PKGBUILD
index 007d1f7ba7f4..a261f34667c0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,17 @@
# Maintainer: Oleksandr Natalenko <oleksandr@natalenko.name>
pkgname=7-zip
-pkgver=22.01
-pkgrel=2
+pkgver=23.01
+pkgrel=1
pkgdesc="File archiver with a high compression ratio"
url=https://7-zip.org
license=('LGPL' 'BSD' 'custom:unRAR')
arch=(x86_64)
makedepends=(uasm meson)
-source=(${url}/a/7z2201-src.tar.xz
+source=(${url}/a/7z2301-src.tar.xz
meson.build)
-sha256sums=('393098730c70042392af808917e765945dc2437dee7aae3cfcc4966eb920fbc5'
- '8b47dd17a5094b487dc343f00113db3c08e94e929a494fbd582bd8c067e539e3')
+sha256sums=('356071007360e5a1824d9904993e8b2480b51b570e8c9faf7c0f58ebe4bf9f74'
+ '211a57a476943e654de7408145b8d626a4dc242e74a3dcb8fc3afd0620792a03')
build() {
arch-meson . build
diff --git a/meson.build b/meson.build
index 14d1ab173900..fb60b232d8df 100644
--- a/meson.build
+++ b/meson.build
@@ -4,7 +4,7 @@ project(
'c',
'cpp',
],
- version: '22.01',
+ version: '23.01',
default_options: [
'warning_level=2',
'werror=true',
@@ -72,6 +72,7 @@ c_files = [
'C/Sha1.c',
'C/Sha256.c',
'C/Sort.c',
+ 'C/SwapBytes.c',
'C/Threads.c',
'C/Xz.c',
'C/XzCrc64.c',
@@ -199,6 +200,7 @@ cpp_files = [
'CPP/7zip/Common/MemBlocks.cpp',
'CPP/7zip/Common/MethodId.cpp',
'CPP/7zip/Common/MethodProps.cpp',
+ 'CPP/7zip/Common/MultiOutStream.cpp',
'CPP/7zip/Common/OffsetStream.cpp',
'CPP/7zip/Common/OutBuffer.cpp',
'CPP/7zip/Common/OutMemStream.cpp',
@@ -353,11 +355,13 @@ project_dependencies = [
dl_dep,
]
+
+
add_project_arguments(
[
- '-D_LZMA_DEC_OPT',
- '-DPROG_VARIANT_Z',
- '-D_7ZIP_ASM',
+ '-DZ7_7ZIP_ASM',
+ '-DZ7_LZMA_DEC_OPT',
+ '-DZ7_PROG_VARIANT_Z',
'-Waddress',
'-Waddress-of-packed-member',
'-Wattributes',
@@ -370,6 +374,7 @@ add_project_arguments(
'-Winit-self',
'-Wint-in-bool-context',
'-Wint-to-pointer-cast',
+ '-Wmisleading-indentation',
'-Wunused',
'-Wunused-macros',
],
@@ -389,6 +394,8 @@ if cpp.get_id() == 'gcc'
'-Wduplicated-cond',
'-Wformat-contains-nul',
'-Wimplicit-fallthrough=5',
+ '-Wmaybe-uninitialized',
+ '-Wmissing-attributes',
],
language: [
'c',
@@ -398,7 +405,6 @@ if cpp.get_id() == 'gcc'
elif cpp.get_id() == 'clang'
add_project_arguments(
[
- '-Wno-sign-conversion',
'-Wno-unused-but-set-variable',
],
language: [
@@ -408,15 +414,6 @@ elif cpp.get_id() == 'clang'
)
endif
-add_project_arguments(
- [
- '-Wno-non-virtual-dtor',
- ],
- language: [
- 'cpp',
- ],
-)
-
project_target = executable('7zz',
[
uasm_files,