summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorwowario2022-07-07 17:34:07 +0000
committerwowario2022-07-07 17:34:07 +0000
commit08cd9d1c34571b6be45ac693c4d379b6f775271b (patch)
tree9cb283b9847b7155c7520e172d5c86a45163689d
parentc743ad5c42caa8fe12328453a500d37c6d0b0a5f (diff)
downloadaur-08cd9d1c34571b6be45ac693c4d379b6f775271b.tar.gz
bump to 2.0.0
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD14
2 files changed, 11 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 36aafb09e0d1..a1502206e356 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = monero-feather-git
pkgdesc = A free Monero desktop wallet
- pkgver = 1.0.1.8219bc4e8c
+ pkgver = 2.0.0
pkgrel = 1
url = https://featherwallet.org
arch = x86_64
@@ -12,7 +12,6 @@ pkgbase = monero-feather-git
depends = boost-libs
depends = libunwind
depends = openssl
- depends = zeromq
depends = hidapi
depends = protobuf
depends = libusb
@@ -21,12 +20,13 @@ pkgbase = monero-feather-git
depends = qrencode
depends = libsodium
depends = expat
- depends = qt5-base
- depends = qt5-websockets
- depends = qt5-svg
+ depends = qt6-base
+ depends = qt6-websockets
+ depends = qt6-svg
depends = tor
depends = zbar
- source = monero-feather-git::git+https://git.featherwallet.org/feather/feather
+ depends = unbound
+ source = monero-feather-git::git+https://github.com/feather-wallet/feather
sha256sums = SKIP
pkgname = monero-feather-git
diff --git a/PKGBUILD b/PKGBUILD
index 7972997359b0..18a80bebf782 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,22 @@
# Maintainer: wowario <wowario[at]protonmail[dot]com>
# Contributor: wowario <wowario[at]protonmail[dot]com>
+# Contributor: tobtoht <dev[at]featherwallet[dot]org>
pkgname='monero-feather-git'
-pkgver=1.0.1.8219bc4e8c
+pkgver=2.0.0
pkgrel=1
pkgdesc='A free Monero desktop wallet'
license=('BSD')
arch=('x86_64')
url="https://featherwallet.org"
-depends=('libzip' 'boost-libs' 'libunwind' 'openssl' 'zeromq' 'hidapi' 'protobuf' 'libusb' 'libudev.so' 'libgcrypt'
- 'qrencode' 'libsodium' 'expat' 'qt5-base' 'qt5-websockets' 'qt5-svg' 'tor' 'zbar')
+depends=('libzip' 'boost-libs' 'libunwind' 'openssl' 'hidapi' 'protobuf' 'libusb' 'libudev.so' 'libgcrypt'
+ 'qrencode' 'libsodium' 'expat' 'qt6-base' 'qt6-websockets' 'qt6-svg' 'tor' 'zbar' 'unbound')
makedepends=('git' 'cmake' 'boost')
-source=("${pkgname}"::"git+https://git.featherwallet.org/feather/feather")
+source=("${pkgname}"::"git+https://github.com/feather-wallet/feather")
sha256sums=('SKIP')
-pkgver() {
- cd "${srcdir}/${pkgname}"
- git describe --long --tags | sed 's/^v//;s/-/.r/;s/-/./'
-}
-
build() {
cd "${srcdir}/${pkgname}"
git submodule update --init --recursive