summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authordumblob2023-08-31 13:58:15 +0200
committerdumblob2023-08-31 13:58:15 +0200
commit08d2eef1e5f336e28e4f145fba207f05710eb971 (patch)
treeb71df8d41f846dbfa61b957ad6facc3544adfb04
parent786e0cd843358671b7db38c9cfc6b6a421628f9b (diff)
downloadaur-08d2eef1e5f336e28e4f145fba207f05710eb971.tar.gz
dependencies: update to current package names
fix compilation warning (missing include for atoi())
-rw-r--r--PKGBUILD7
-rw-r--r--sinac.c1
2 files changed, 5 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8267b581461a..784f571e5b9b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,17 @@
# Contributor: Mathieu Boespflug <mboes@tweag.net>
# Maintainer: John Wallaby <drunken.wallaby@gmail.com>
+# Maintainer: dumblob <dumblob@gmail.com>
pkgname=sinac
pkgver=0.1.2
-pkgrel=4
+pkgrel=5
pkgdesc="A cleaner/simpler alternative to xautolock for screen locking."
url="http://www.suckless.org/pipermail/dwm/2007-December/004691.html"
arch=('i686' 'x86_64')
license=('GPL')
depends=(libxss)
-makedepends=(xproto scrnsaverproto)
+makedepends=(libxss)
source=(sinac.c)
-md5sums=('d7d3642a880636015bd507edf2f04ca2')
+md5sums=('29d3cce1de6886f69f0b8ee33f041e17')
package() {
cd $srcdir
gcc sinac.c -lX11 -lXss -lXext -o sinac
diff --git a/sinac.c b/sinac.c
index c39d6b307de7..4591a156b182 100644
--- a/sinac.c
+++ b/sinac.c
@@ -27,6 +27,7 @@
#include <X11/extensions/scrnsaver.h>
#include <stdio.h>
+#include <stdlib.h>
#define VERSION "0.1.2"