summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAdrien Sohier2015-06-08 15:21:19 +0200
committerAdrien Sohier2015-06-08 15:21:19 +0200
commit08d7fac18ed866ea6d559a3d34097642c4079bdc (patch)
tree492d06375bb650b863cc5f1a59c685452e4969cb
downloadaur-08d7fac18ed866ea6d559a3d34097642c4079bdc.tar.gz
init
-rw-r--r--.SRCINFO25
-rw-r--r--24hour.patch13
-rw-r--r--PKGBUILD49
3 files changed, 87 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8046a1a9d06b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+pkgbase = i3lock-lixxia-git
+ pkgdesc = An improved screenlocker based upon XCB and PAM (Lixxia fork)
+ pkgver = cd615c
+ pkgrel = 2
+ url = https://github.com/Lixxia/i3lock
+ arch = i686
+ arch = x86_64
+ groups = i3
+ license = MIT
+ depends = xcb-util-image
+ depends = libev
+ depends = cairo
+ depends = libxkbcommon-x11
+ provides = i3lock
+ conflicts = i3lock
+ replaces = i3lock
+ options = docs
+ backup = etc/pam.d/i3lock
+ source = git://github.com/Lixxia/i3lock.git
+ source = 24hour.patch
+ md5sums = SKIP
+ md5sums = 2b4a24174ab2335049bfafcf04e9b24e
+
+pkgname = i3lock-lixxia-git
+
diff --git a/24hour.patch b/24hour.patch
new file mode 100644
index 000000000000..b8a7c6e4a3b7
--- /dev/null
+++ b/24hour.patch
@@ -0,0 +1,13 @@
+Only in b: tags
+diff -ru a/unlock_indicator.c b/unlock_indicator.c
+--- a/unlock_indicator.c 2015-05-22 11:00:01.849040047 +0200
++++ b/unlock_indicator.c 2015-05-22 11:00:45.945473675 +0200
+@@ -25,7 +25,7 @@
+ #define BUTTON_SPACE (BUTTON_RADIUS + 5)
+ #define BUTTON_CENTER (BUTTON_RADIUS + 5)
+ #define BUTTON_DIAMETER (2 * BUTTON_SPACE)
+-#define TIME_FORMAT "%l:%M%p"
++#define TIME_FORMAT "%H:%M"
+
+ /*******************************************************************************
+ * Variables defined in i3lock.c.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cf3af65ef20f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,49 @@
+# Maintainer: Adrien Sohier <adrien.sohier@art-software.fr>
+
+pkgname=i3lock-lixxia-git
+pkgver=cd615c
+pkgrel=2
+pkgdesc="An improved screenlocker based upon XCB and PAM (Lixxia fork)"
+arch=('i686' 'x86_64')
+url="https://github.com/Lixxia/i3lock"
+license=('MIT')
+groups=("i3")
+depends=('xcb-util-image' 'libev' 'cairo' 'libxkbcommon-x11')
+options=('docs')
+replaces=('i3lock')
+provides=('i3lock')
+conflicts=('i3lock')
+backup=("etc/pam.d/i3lock")
+source=("git://github.com/Lixxia/i3lock.git"
+ "24hour.patch")
+md5sums=('SKIP'
+ '2b4a24174ab2335049bfafcf04e9b24e')
+
+pkgver() {
+ cd "${srcdir}/i3lock"
+ git describe --always | cut -c2- | tr "-" "."
+}
+
+prepare() {
+ cd "${srcdir}/i3lock"
+ patch -Np1 -i "${srcdir}/24hour.patch"
+}
+
+build() {
+ cd "${srcdir}/i3lock"
+
+ make
+ gzip i3lock.1
+}
+
+package() {
+ cd "${srcdir}/i3lock"
+ make DESTDIR="${pkgdir}" install
+
+ install -Dm644 i3lock.1.gz ${pkgdir}/usr/share/man/man1/i3lock.1.gz
+ install -Dm644 LICENSE ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
+ make clean
+}
+
+# vim:set ts=2 sw=2 et:
+