summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWill Handley2022-06-07 21:26:25 +0100
committerWill Handley2022-06-07 21:26:25 +0100
commit08e4332740b36d16a73d5a4bccf21591667d2923 (patch)
treefd9753641050f352208577497ed09f257d49bf6d
parent69f109f4e4bc0b5847b598cf6da51522ec702d5c (diff)
downloadaur-08e4332740b36d16a73d5a4bccf21591667d2923.tar.gz
Updated
-rw-r--r--.SRCINFO7
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD25
3 files changed, 18 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a19f00309aee..cc374d9e7cac 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = python-pywwt
pkgdesc = Python interface to the Windows and Web client of WorldWide Telescope
pkgver = 0.9.0
- pkgrel = 2
+ pkgrel = 4
url = https://github.com/WorldWideTelescope/pywwt
arch = any
license = BSD
@@ -18,8 +18,7 @@ pkgbase = python-pywwt
depends = python-flask
depends = python-six
options = !emptydirs
- source = https://github.com/WorldWideTelescope/pywwt/archive/v0.9.0.tar.gz
- sha256sums = e4efa7fbd5d729b94fb1e6124a55dc37071dca15959f210350133cb315c0ffdb
+ source = https://files.pythonhosted.org/packages/source/p/pywwt/pywwt-0.9.0.tar.gz
+ sha256sums = a918b612f2164ff7c2167adba9a465659f047a4eb0772ae19bd8905531795925
pkgname = python-pywwt
-
diff --git a/.gitignore b/.gitignore
index b20752a93bec..a6b8c850ccb9 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,4 +1,5 @@
*.tar.gz
*.tar.xz
+*.tar.zst
pkg/
src/
diff --git a/PKGBUILD b/PKGBUILD
index 2c7cd55b52c6..c058dd05e8fe 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Will Handley <wh260@cam.ac.uk> (aur.archlinux.org/account/wjhandley)
-_modulename=pywwt
-pkgname=python-$_modulename
+pkgname=python-pywwt
+_name=${pkgname#python-}
pkgver=0.9.0
-pkgrel=2
+pkgrel=4
pkgdesc="Python interface to the Windows and Web client of WorldWide Telescope"
arch=(any)
url="https://github.com/WorldWideTelescope/pywwt"
@@ -16,13 +16,16 @@ replaces=()
backup=()
options=(!emptydirs)
install=
-source=("${url}/archive/v${pkgver}.tar.gz")
-sha256sums=('e4efa7fbd5d729b94fb1e6124a55dc37071dca15959f210350133cb315c0ffdb')
-#check() {
-# cd "$srcdir/CAMB-$pkgver/"
-# python setup.py test
-#}
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz")
+sha256sums=(a918b612f2164ff7c2167adba9a465659f047a4eb0772ae19bd8905531795925)
+build() {
+ cd "$srcdir/$_name-$pkgver"
+ sed -i 's/ensure_python/#ensure_python/' setup.py
+ python -m build --wheel --no-isolation
+}
+
package() {
- cd "$srcdir/pywwt-$pkgver/"
- python setup.py install --root="$pkgdir/" --optimize=1
+ cd "$srcdir/$_name-$pkgver"
+ python -m installer --destdir="$pkgdir" dist/*.whl
}
+