summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorYannick Le Guen2015-06-12 18:06:42 +0200
committerYannick Le Guen2015-06-12 18:06:42 +0200
commit08f5c2ba1eef0ee7dcb7efbf78269ade291da55e (patch)
treed0cc6782696a6f1a4af50319bbc16f61930a3434
downloadaur-08f5c2ba1eef0ee7dcb7efbf78269ade291da55e.tar.gz
Initial import
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD32
-rw-r--r--xfce4-linelight-plugin.install17
3 files changed, 70 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..dfba0408b18b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = xfce4-linelight-plugin
+ pkgdesc = A simple frontend for the locate search.
+ pkgver = 0.1.7
+ pkgrel = 8
+ url = http://goodies.xfce.org/projects/panel-plugins/xfce4-linelight-plugin
+ install = xfce4-linelight-plugin.install
+ arch = i686
+ arch = x86_64
+ groups = xfce4-goodies
+ license = GPL2
+ depends = xfce4-panel
+ depends = libxfcegui4
+ depends = mlocate
+ options = !libtool
+ source = http://ftp.de.debian.org/debian/pool/main/x/xfce4-linelight-plugin/xfce4-linelight-plugin_0.1.7.orig.tar.bz2
+ source = http://lionel.lefolgoc.net/misc/01_port-to-xfcerc.patch
+ md5sums = 1915cd661aafd09c08e04d65775a78ce
+ md5sums = 8b04c70513ecbf74412ea3ed230c46a3
+
+pkgname = xfce4-linelight-plugin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..aea071e22a37
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Spike29 <leguen.yannick@gmail.com>
+# Contributor: Michael Pfeuti <m_pfeuti@students.unibe.ch>
+
+pkgname='xfce4-linelight-plugin'
+pkgver='0.1.7'
+pkgrel='8'
+pkgdesc='A simple frontend for the locate search.'
+arch=('i686' 'x86_64')
+license=('GPL2')
+url='http://goodies.xfce.org/projects/panel-plugins/xfce4-linelight-plugin'
+groups=('xfce4-goodies')
+depends=('xfce4-panel' 'libxfcegui4' 'mlocate')
+options=('!libtool')
+install="${pkgname}.install"
+source=("http://ftp.de.debian.org/debian/pool/main/x/${pkgname}/${pkgname}_${pkgver}.orig.tar.bz2"
+ "http://lionel.lefolgoc.net/misc/01_port-to-xfcerc.patch")
+md5sums=('1915cd661aafd09c08e04d65775a78ce'
+ '8b04c70513ecbf74412ea3ed230c46a3')
+
+build() {
+ cd "$srcdir/"
+ patch -p0 -i 01_port-to-xfcerc.patch
+ cd "$pkgname-$pkgver/"
+ ./configure --prefix=/usr --sysconfdir=/etc --libexecdir=/usr/lib/ \
+ --localstatedir=/var --disable-static
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver/"
+ make DESTDIR="$pkgdir" install
+}
diff --git a/xfce4-linelight-plugin.install b/xfce4-linelight-plugin.install
new file mode 100644
index 000000000000..a7b986843c7e
--- /dev/null
+++ b/xfce4-linelight-plugin.install
@@ -0,0 +1,17 @@
+post_install() {
+ gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
+ updatedb
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+post_remove() {
+ gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
+}
+
+op=$1
+shift
+
+$op $*