summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoaquin2018-02-01 13:18:58 -0500
committerJoaquin2018-02-01 13:18:58 -0500
commit092d4c390efc24d08736099421ca1e79ac0012bb (patch)
treec1b89cc1f557d0a987acd8a486639d2fe1bfc383
downloadaur-092d4c390efc24d08736099421ca1e79ac0012bb.tar.gz
Initial upload: gtk-arc-flatabulous-theme 20180201-1
Creating gtk-arc-flatabulous-theme pkgbuild
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD35
2 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..024f7dea2581
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = gtk-arc-flatabulous-theme
+ pkgdesc = Arc theme with Flatabulous window controls.
+ pkgver = 20180201
+ pkgrel = 1
+ url = https://github.com/andreisergiu98/arc-flatabulous-theme
+ arch = any
+ license = GPL3
+ makedepends = git
+ makedepends = gtk3
+ makedepends = sassc
+ optdepends = gtk-engine-murrine: for gtk2 themes
+ optdepends = gnome-themes-standard: for gtk2 themes
+ optdepends = arc-icon-theme: recommended icon theme
+ optdepends = gtk3: for gtk3 themes
+ source = https://github.com/andreisergiu98/arc-flatabulous-theme/archive/20180201.tar.gz
+ sha256sums = 37c4a748273ed32cc5ec16fa083dfc4f708374b1a9811b03baf311265f6b5f4d
+
+pkgname = gtk-arc-flatabulous-theme
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cb4c6b07c74c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Joaquin Garmendia <joaquingc123 at gmail dot com>
+# Contributor: Orestis Floros <orestisf1993@gmail.com>
+
+# All my PKGBUILDs can be found in https://www.github.com/joaquingx/PKGBUILDs
+
+pkgname=gtk-arc-flatabulous-theme
+pkgver=20180201
+pkgrel=1
+pkgdesc="Arc theme with Flatabulous window controls."
+arch=('any')
+url="https://github.com/andreisergiu98/${pkgname#gtk\-}"
+license=('GPL3')
+makedepends=('git' 'gtk3' 'sassc')
+optdepends=('gtk-engine-murrine: for gtk2 themes'
+ 'gnome-themes-standard: for gtk2 themes'
+ 'arc-icon-theme: recommended icon theme'
+ 'gtk3: for gtk3 themes'
+ )
+source=("https://github.com/andreisergiu98/${pkgname#gtk\-}/archive/${pkgver}.tar.gz")
+sha256sums=('37c4a748273ed32cc5ec16fa083dfc4f708374b1a9811b03baf311265f6b5f4d')
+
+prepare() {
+ cd "${srcdir}/${pkgname#gtk\-}-${pkgver}"
+ autoreconf -fi
+}
+
+build() {
+ cd "${srcdir}/${pkgname#gtk\-}-${pkgver}"
+ ./configure --prefix=/usr
+}
+
+package() {
+ cd "${srcdir}/${pkgname#gtk\-}-${pkgver}"
+ make DESTDIR="${pkgdir}" install
+}