summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDoug Newgard2014-08-01 09:17:22 -0500
committerDoug Newgard2014-08-01 09:17:22 -0500
commit09315f5aa791fc95620e3d3a81d1b788beb72e39 (patch)
tree2a009bb591b87c05d12eb255329d7b7e455264c4
downloadaur-09315f5aa791fc95620e3d3a81d1b788beb72e39.tar.gz
Initial PKGBUILD
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD28
3 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7bdfac232661
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = epymc
+ pkgdesc = Media Center based on EFL
+ pkgver = 1.0.0beta1
+ pkgrel = 1
+ url = https://github.com/DaveMDS/epymc
+ arch = any
+ license = GPL3
+ depends = python2-efl
+ optdepends = mutagen: music module
+ optdepends = lirc: remote contol support
+ optdepends = sdlmame: MAME module
+ source = https://github.com/DaveMDS/epymc/archive/v1.0.0-beta1.tar.gz
+ sha256sums = SKIP
+
+pkgname = epymc
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..71a9d16c2b38
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*~
+*/
+*.tar.*
+*.log
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..885c2275177a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Doug Newgard <scimmia at archlinux dot info>
+
+pkgname=epymc
+_pkgver=1.0.0-beta1
+pkgver=1.0.0beta1
+pkgrel=1
+pkgdesc="Media Center based on EFL"
+arch=('any')
+url="https://github.com/DaveMDS/epymc"
+license=('GPL3')
+depends=('python2-efl')
+optdepends=('mutagen: music module'
+ 'lirc: remote contol support'
+ 'sdlmame: MAME module')
+source=("https://github.com/DaveMDS/$pkgname/archive/v$_pkgver.tar.gz")
+sha256sums=('SKIP')
+
+prepare() {
+ cd "$srcdir/$pkgname-$_pkgver"
+
+ find -name "*.py" -exec sed -i 's/env python$/&2/' {} \;
+}
+
+package() {
+ cd "$srcdir/$pkgname-$_pkgver"
+
+ python2 setup.py install --root="$pkgdir" --optimize=1
+}