summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCaleb Maclennan2021-12-29 13:56:47 +0300
committerCaleb Maclennan2021-12-29 13:56:47 +0300
commit0939c56399304c2fc856b2726e46fe278da8fdda (patch)
tree353af4757dd7bc5c24c3470db48c2db0bdb693cf
parent00d0fed921924d35ff8826f511209799344612cf (diff)
downloadaur-0939c56399304c2fc856b2726e46fe278da8fdda.tar.gz
upgpkg: chan-sccp 4.3.5-1
upstream release
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD19
2 files changed, 15 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 35d868a8b17f..af765b0ae622 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = chan-sccp
pkgdesc = Cisco SCCP channel driver for Asterisk, alternative to chan_skinny
- pkgver = 4.3.4
- pkgrel = 2
+ pkgver = 4.3.5
+ pkgrel = 1
url = https://chan-sccp.github.io/chan-sccp
arch = x86_64
arch = i686
@@ -11,8 +11,8 @@ pkgbase = chan-sccp
depends = openssl
depends = zlib
backup = etc/asterisk/sccp.conf
- source = chan-sccp-4.3.4.tar.gz::https://github.com/chan-sccp/chan-sccp/archive/v4.3.4.tar.gz
- sha256sums = 29b808e2329da46eba2a163615202d9fa89c4b6db00ec3b9589ec12ab76e7882
+ source = chan-sccp-4.3.5.tgz::https://github.com/chan-sccp/chan-sccp/archive/v4.3.5.tar.gz
+ sha256sums = ee7ce93f282cc99875566016520085a22feabc97649188571dfda00c789985fe
pkgname = chan-sccp
depends = asterisk
diff --git a/PKGBUILD b/PKGBUILD
index 4e4eb9df74d4..a0fd9ac67ed6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,21 +2,24 @@
# Maintainer: Michael Manley <mmanley@nasutek.com>
pkgname=chan-sccp
-pkgver=4.3.4
-pkgrel=2
+pkgver=4.3.5
+pkgrel=1
pkgdesc='Cisco SCCP channel driver for Asterisk, alternative to chan_skinny'
arch=(x86_64 i686)
url="https://chan-sccp.github.io/$pkgname"
license=(GPL)
-depends=(libtool openssl zlib)
+depends=(libtool
+ openssl
+ zlib)
makedepends=(asterisk)
backup=('etc/asterisk/sccp.conf')
-source=("$pkgname-$pkgver.tar.gz::https://github.com/$pkgname/$pkgname/archive/v${pkgver/_/-}.tar.gz")
-sha256sums=('29b808e2329da46eba2a163615202d9fa89c4b6db00ec3b9589ec12ab76e7882')
+_archive="$pkgname-${pkgver/_/-}"
+source=("$_archive.tgz::https://github.com/$pkgname/$pkgname/archive/v${pkgver/_/-}.tar.gz")
+sha256sums=('ee7ce93f282cc99875566016520085a22feabc97649188571dfda00c789985fe')
build() {
local _asterisk="$(asterisk -V | sed -e 's/.* \([0-9]\+\.[0-9]\+\).*/\1/')"
- cd "$pkgname-${pkgver/_/-}"
+ cd "$_archive"
./configure \
--prefix=/usr \
--with-asterisk-version="$_asterisk"
@@ -28,8 +31,8 @@ build() {
# on the version it built against so that upgrades don't break unexpectedly
package(){
local _asterisk="=$(pacman -Qn asterisk | awk -F'[ -]' '{ print $2 }')"
- depends=(asterisk$_asterisk ${depends[@]})
- cd "$pkgname-${pkgver/_/-}"
+ depends=(asterisk$_asterisk "${depends[@]}")
+ cd "$_archive"
make DESTDIR="$pkgdir" install
}