summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTércio Martins2021-11-14 17:56:02 -0300
committerTércio Martins2021-11-14 17:56:02 -0300
commit093dbb05f766c1fee68b782d9b3c8836a46334f1 (patch)
treeef5c30e3f0703d0ca3f6bb0ff11f2ced90d19153
parent35d65f9724247f7da1241e6d8287ab0a7a330007 (diff)
downloadaur-093dbb05f766c1fee68b782d9b3c8836a46334f1.tar.gz
Fixes to compile with dependencies "opencolorio1" and "libzip"
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD17
2 files changed, 17 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e78abf370216..c4ac553d1f59 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = openfx-arena-git
pkgdesc = Extra OpenFX plugins for Natron
- pkgver = Natron.2.4.0.r0.ge9ab79a
+ pkgver = Natron.2.4.1.r0.g2d37552
pkgrel = 1
url = https://github.com/NatronGitHub/openfx-arena
arch = x86_64
@@ -34,4 +34,3 @@ pkgbase = openfx-arena-git
sha512sums = SKIP
pkgname = openfx-arena-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 95716ff5fce5..4f12cc273598 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
# Contributor: Luca Weiss <luca (at) z3ntu (dot) xyz>
pkgname=openfx-arena-git
-pkgver=Natron.2.4.0.r0.ge9ab79a
+pkgver=Natron.2.4.1.r0.g2d37552
pkgrel=1
arch=('x86_64')
pkgdesc="Extra OpenFX plugins for Natron"
@@ -32,6 +32,11 @@ sha512sums=('SKIP'
'SKIP'
'SKIP')
+pkgver() {
+ cd ${_pkgname}
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
prepare() {
cd ${_pkgname}
git submodule init
@@ -52,6 +57,16 @@ prepare() {
git submodule init
git config submodule.tinydir.url ${srcdir}/tinydir
git submodule update
+ cd ../../../
+
+# Change OpenColorIO library references to the version of "opencolorio1" package
+ find OpenFX-IO/IOSupport/ -name GenericOCIO.* \
+ -exec sed -i 's/include <OpenColorIO/include <OpenColorIO1/' {} \;
+
+# Solve a problem in the linking of the "Extra" plugins,
+# caused by a misconfiguration of pkgconfig in the "libzip" package
+ sed -i '/ZIP_LINKFLAGS/ s|\$.*libs.*|-lbz2 -llzma -lzstd -lgnutls -lnettle -lz|' \
+ Makefile.master
}
build() {