summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSammysHP2018-01-07 16:11:04 +0100
committerSammysHP2018-01-07 16:11:04 +0100
commit094371f996bb1c3d338aeeb6e59511765b195004 (patch)
tree00087e096b95174f3a99a3332d6dbfc3df0182f3
downloadaur-094371f996bb1c3d338aeeb6e59511765b195004.tar.gz
Import from [community]
Package was removed from [community] at 2017-11-25.
-rw-r--r--.SRCINFO19
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD39
-rw-r--r--sqliteman-qscintilla-2.10.patch11
4 files changed, 73 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..19fed352b168
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+# Generated by mksrcinfo v8
+# Sun Jan 7 15:10:58 UTC 2018
+pkgbase = sqliteman
+ pkgdesc = The best developer's and/or admin's GUI tool for Sqlite3 in the world
+ pkgver = 1.2.2
+ pkgrel = 11
+ url = http://sqliteman.com/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = cmake
+ depends = qscintilla-qt4
+ source = http://downloads.sourceforge.net/sqliteman/sqliteman-1.2.2.tar.gz
+ source = sqliteman-qscintilla-2.10.patch
+ md5sums = 5ecdf710e23606e1b924f740ea69306d
+ md5sums = 9922a1f404f2381564abfb9096973911
+
+pkgname = sqliteman
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..ba7822d168fd
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+/pkg/
+/src/
+*.tar.xz
+*.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..47f8e5a50ea8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# $Id$
+# Maintainer: Sergej Pupykin <pupykin.s+arch@gmail.com>
+# Contributor: Geoffroy Carrier <geoffroy@archlinux.org>
+# Contributor: Roman Porizka <artee@beer.cz>
+# Contributor: Daniel J Griffiths <ghost1227@archlinux.us>
+
+pkgname=sqliteman
+pkgver=1.2.2
+pkgrel=11
+pkgdesc="The best developer's and/or admin's GUI tool for Sqlite3 in the world"
+arch=('i686' 'x86_64')
+url="http://sqliteman.com/"
+license=('GPL')
+depends=('qscintilla-qt4')
+makedepends=('cmake')
+source=("http://downloads.sourceforge.net/${pkgname}/${pkgname}-${pkgver}.tar.gz" sqliteman-qscintilla-2.10.patch)
+md5sums=('5ecdf710e23606e1b924f740ea69306d'
+ '9922a1f404f2381564abfb9096973911')
+
+prepare() {
+ mkdir build
+
+# Fix qscintilla 2.10 detection
+ cd $pkgname-$pkgver
+ patch -p1 -i ../sqliteman-qscintilla-2.10.patch
+}
+
+build() {
+ cd build
+ cmake ../${pkgname}-${pkgver} \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_BUILD_TYPE=Release
+ make
+}
+
+package() {
+ cd build
+ make DESTDIR="${pkgdir}" install
+}
diff --git a/sqliteman-qscintilla-2.10.patch b/sqliteman-qscintilla-2.10.patch
new file mode 100644
index 000000000000..e1a362812596
--- /dev/null
+++ b/sqliteman-qscintilla-2.10.patch
@@ -0,0 +1,11 @@
+--- sqliteman-1.2.2/cmake/modules/FindQScintilla.cmake.orig 2017-02-25 12:02:29.500716404 +0000
++++ sqliteman-1.2.2/cmake/modules/FindQScintilla.cmake 2017-02-25 12:02:55.167341296 +0000
+@@ -21,7 +21,7 @@
+ "${QT_INCLUDE_DIR}/Qsci" /usr/include /usr/include/Qsci
+ )
+
+- SET(QSCINTILLA_NAMES ${QSCINTILLA_NAMES} qscintilla2 libqscintilla2)
++ SET(QSCINTILLA_NAMES ${QSCINTILLA_NAMES} qscintilla2 libqscintilla2 qscintilla2_qt4 libqscintilla2_qt4)
+ FIND_LIBRARY(QSCINTILLA_LIBRARY
+ NAMES ${QSCINTILLA_NAMES}
+ PATHS ${QT_LIBRARY_DIR}