summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorL. Bradley LaBoon2024-02-06 19:52:00 -0500
committerL. Bradley LaBoon2024-02-06 19:52:00 -0500
commit095a97df7ccb3efdb29b1b61de35c4d585c0ac0a (patch)
tree599fcdd5ed872a3c427142c21028fc996578eebd
parenta1280864dc7cab1214b76a581baecf115e96ede1 (diff)
downloadaur-095a97df7ccb3efdb29b1b61de35c4d585c0ac0a.tar.gz
Updated to 9.2.0
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD8
-rw-r--r--splunk.install2
-rw-r--r--splunk.service25
4 files changed, 23 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4694d8118222..05221283662e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = splunk
pkgdesc = Statistical analysis and search tool for logs and machine data
- pkgver = 9.1.3.0
+ pkgver = 9.2.0.0
pkgrel = 1
epoch = 3
url = https://www.splunk.com/
@@ -11,10 +11,10 @@ pkgbase = splunk
source = splunk.service
source = splunk.sysusers
source = splunk.tmpfiles
- sha256sums = f4e831e3b281f1e677a3597fc85162cd347803ea3b41605f990347000e5caff9
+ sha256sums = b6e93690f033416fd765fd7cb97147a1872c3f5ecc3dad13714d83f765c6291e
sha256sums = 236deb352218f9551df894efd613aad201afb20713ac563ab381f68b6ffce853
sha256sums = 56b70a2395270fc038987241504df11c390f3234d5be640bbc6a311b978e8475
- source_x86_64 = https://download.splunk.com/products/splunk/releases/9.1.3/linux/splunk-9.1.3-d95b3299fa65-Linux-x86_64.tgz
- sha256sums_x86_64 = bc57ed6197ea5dc411378b46377641d41ea8d18fc63f43ba7c7a6ed5888e4f69
+ source_x86_64 = https://download.splunk.com/products/splunk/releases/9.2.0/linux/splunk-9.2.0-1fff88043d5f-Linux-x86_64.tgz
+ sha256sums_x86_64 = b5ba92a2123a21e02f52f632271aa955e59a257e92d3503466de5f24d3e0ce7b
pkgname = splunk
diff --git a/PKGBUILD b/PKGBUILD
index 72059bd334a6..4e9e17497979 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: L. Bradley LaBoon <me@bradleylaboon.com>
pkgname=splunk
-basever=9.1.3
-splunkver=${basever}-d95b3299fa65
+basever=9.2.0
+splunkver=${basever}-1fff88043d5f
# Splunk is inconsistent with the length of their version numbers
if [ ${#basever} -gt 5 ]; then
pkgver=${basever}
@@ -17,10 +17,10 @@ license=('custom')
install="$pkgname.install"
source=("$pkgname.service" "$pkgname.sysusers" "$pkgname.tmpfiles")
source_x86_64=("https://download.splunk.com/products/splunk/releases/$basever/linux/$pkgname-$splunkver-Linux-x86_64.tgz")
-sha256sums=('f4e831e3b281f1e677a3597fc85162cd347803ea3b41605f990347000e5caff9'
+sha256sums=('b6e93690f033416fd765fd7cb97147a1872c3f5ecc3dad13714d83f765c6291e'
'236deb352218f9551df894efd613aad201afb20713ac563ab381f68b6ffce853'
'56b70a2395270fc038987241504df11c390f3234d5be640bbc6a311b978e8475')
-sha256sums_x86_64=('bc57ed6197ea5dc411378b46377641d41ea8d18fc63f43ba7c7a6ed5888e4f69')
+sha256sums_x86_64=('b5ba92a2123a21e02f52f632271aa955e59a257e92d3503466de5f24d3e0ce7b')
options=(!strip)
package() {
diff --git a/splunk.install b/splunk.install
index 5a7dfa9459b0..18f608f63f5d 100644
--- a/splunk.install
+++ b/splunk.install
@@ -28,7 +28,6 @@ post_install() {
pre_upgrade() {
echo "Attempting to stop the installed Splunk Server..."
- $SPLUNK_HOME/bin/splunk stop
systemctl stop splunk
}
@@ -56,6 +55,5 @@ post_upgrade() {
pre_remove() {
echo "Attempting to stop the installed Splunk Server..."
- $SPLUNK_HOME/bin/splunk stop
systemctl stop splunk
}
diff --git a/splunk.service b/splunk.service
index 6c530d8f4849..1f5b10500866 100644
--- a/splunk.service
+++ b/splunk.service
@@ -1,17 +1,22 @@
[Unit]
-Description=Splunk
-Wants=network.target
-After=network.target
+Description=Splunk Enterprise
+After=network-online.target
+Wants=network-online.target
[Service]
-Type=forking
-RemainAfterExit=yes
+Type=simple
+Restart=always
+ExecStart=/opt/splunk/bin/splunk _internal_launch_under_systemd --answer-yes --no-prompt --accept-license
+KillMode=mixed
+KillSignal=SIGINT
+TimeoutStopSec=360
+LimitNOFILE=65536
+LimitRTPRIO=99
+SuccessExitStatus=51 52
+RestartPreventExitStatus=51
+RestartForceExitStatus=52
User=splunk
-ExecStart=/opt/splunk/bin/splunk start --answer-yes --no-prompt --accept-license
-ExecStop=/opt/splunk/bin/splunk stop
-ExecReload=/opt/splunk/bin/splunk restart
-StandardOutput=syslog
-TimeoutSec=500
+Group=splunk
[Install]
WantedBy=multi-user.target