summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDustin Falgout2015-06-08 06:13:56 -0500
committerDustin Falgout2015-06-08 06:13:56 -0500
commit095bd8dd73354cd4d154122df2d7400dd0373b66 (patch)
tree716a0fa648cdfc761d93051c6d2da4f603b1b944
downloadaur-095bd8dd73354cd4d154122df2d7400dd0373b66.tar.gz
aurweb 3.5 -> 4.0 migration
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD30
-rw-r--r--theme.install10
3 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3ca626ef7e8a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = lightdm-webkit-theme-userdock
+ pkgdesc = User Dock theme for the LightDM Webkit Greeter
+ pkgver = 1.0.2
+ pkgrel = 2
+ url = http://www.antergos.com
+ install = theme.install
+ arch = any
+ license = GPLv2
+ depends = lightdm-webkit2-greeter
+ source = lightdm-webkit-theme-userdock-1.0.2.tar.gz::https://github.com/lots0logs/lightdm-webkit-theme-userdock/archive/1.0.2.tar.gz
+ md5sums = b958fabf99ebdf023d9accff35341ac0
+
+pkgname = lightdm-webkit-theme-userdock
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..727e2e3325e8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Dustin Falgout <dustin@antergos.info>
+
+pkgname=lightdm-webkit-theme-userdock
+_pkgname=userdock
+pkgver=1.0.2
+pkgrel=2
+pkgdesc="User Dock theme for the LightDM Webkit Greeter"
+arch=('any')
+url="http://www.antergos.com"
+license=('GPLv2')
+depends=('lightdm-webkit2-greeter')
+install=theme.install
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/lots0logs/${pkgname}/archive/${pkgver}.tar.gz")
+md5sums=('b958fabf99ebdf023d9accff35341ac0')
+
+build()
+{
+ cd ${srcdir}/${pkgname}-${pkgver}
+}
+
+package()
+{
+ cd ${pkgdir}
+ mkdir -p usr/share/lightdm-webkit/themes
+ cd usr/share/lightdm-webkit/themes
+ cp -dpr --no-preserve=ownership ${srcdir}/${pkgname}-${pkgver} ${_pkgname}
+ msg "Removing .git files"
+ cd ${_pkgname}
+ rm -rf .gitignore
+}
diff --git a/theme.install b/theme.install
new file mode 100644
index 000000000000..0d6d87a3c887
--- /dev/null
+++ b/theme.install
@@ -0,0 +1,10 @@
+post_install()
+{
+ echo "Set greeter-session=light-webkit2-greeter in /etc/lightdm/lightdm.conf"
+ echo "Also set webkit-theme=userdock in /etc/lightdm/lightdm-webkit2-greeter.conf"
+ echo "See https://wiki.archlinux.org/index.php/LightDM#Testing on how to test greeters"
+
+ echo "Please note that this theme doesn't support choosing the session at login,"
+ echo "and must be changed in /etc/lightdm/lightdm.conf with user-session=SESSION"
+}
+