summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorOrhun Parmaksız2021-10-05 19:34:55 +0300
committerOrhun Parmaksız2021-10-05 19:34:55 +0300
commit09758cdc0e38ee1bb0b6205d533627f86ce6e2fc (patch)
tree80b999cedd88e83be49f0f122df559e37d4aced3
parent25d034d9387628001918c84b20981f1e1cbde5a4 (diff)
downloadaur-09758cdc0e38ee1bb0b6205d533627f86ce6e2fc.tar.gz
upgpkg: xplr-git 0.15.0.r4.gac1b407-1
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD12
2 files changed, 10 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 804c7f27f93b..c44d0b3a53d5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = xplr-git
pkgdesc = A hackable, minimal, fast TUI file explorer (git)
- pkgver = 0.14.3.r0.g32a32e9
+ pkgver = 0.15.0.r4.gac1b407
pkgrel = 1
url = https://github.com/sayanarijit/xplr
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index 27da6f69f28a..449a2fa2c9a8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# https://github.com/orhun/pkgbuilds
pkgname=xplr-git
-pkgver=0.14.3.r0.g32a32e9
+pkgver=0.15.0.r4.gac1b407
pkgrel=1
pkgdesc="A hackable, minimal, fast TUI file explorer (git)"
arch=('x86_64')
@@ -20,14 +20,20 @@ pkgver() {
git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
+prepare() {
+ cd "${pkgname%-git}"
+ cargo fetch --locked
+}
+
build() {
cd "${pkgname%-git}"
- cargo build --locked --release
+ cargo build --frozen --release
}
check() {
cd "${pkgname%-git}"
- cargo test --locked --release
+ cargo build --frozen
+ cargo test --frozen
}
package() {