summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristopher Arndt2021-04-22 15:35:52 +0200
committerChristopher Arndt2021-04-22 15:35:52 +0200
commit098728214834ef7f2ef2109270d96a8106670f1d (patch)
treed3cd35a92e5284fc6ccce8e47c2a3e886c141b99
parent229c6230585a0ad4e5ea2c1fcbcf80c9b88f96d8 (diff)
downloadaur-098728214834ef7f2ef2109270d96a8106670f1d.tar.gz
Fix compilation
Signed-off-by: Christopher Arndt <chris@chrisarndt.de>
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD7
2 files changed, 6 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d4722fdfdbd3..0a95726326d2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,13 @@
pkgbase = tunefish4-git
pkgdesc = An additive wavetable-based synthesizer VST plugin (git version)
- pkgver = 4.2.0.r90.a199cb0
+ pkgver = 4.3.0.r106.07774d9
pkgrel = 1
url = http://www.tunefish-synth.com/
arch = x86_64
groups = vst-plugins
license = GPL3
makedepends = git
+ makedepends = steinberg-vst36
depends = webkit2gtk
provides = tunefish4
conflicts = tunefish4
diff --git a/PKGBUILD b/PKGBUILD
index 344097684fff..78e991142851 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_pkgname=tunefish4
pkgname="${_pkgname}-git"
-pkgver=4.2.0.r90.a199cb0
+pkgver=4.3.0.r106.07774d9
pkgrel=1
pkgdesc="An additive wavetable-based synthesizer VST plugin (git version)"
arch=('x86_64')
@@ -11,7 +11,7 @@ url="http://www.tunefish-synth.com/"
license=("GPL3")
groups=('vst-plugins')
depends=('webkit2gtk')
-makedepends=('git')
+makedepends=('git' 'steinberg-vst36')
provides=("${_pkgname}")
conflicts=("${_pkgname}" "${_pkgname}-vst-bin")
source=("${_pkgname}::git://github.com/paynebc/tunefish.git"
@@ -33,12 +33,13 @@ prepare() {
cd "${srcdir}/${_pkgname}"
msg2 "Patching JUCE graphics..."
- patch -p1 -N -i "${srcdir}/juce-pixel.patch"
+ patch -p1 -N -r - -i "${srcdir}/juce-pixel.patch" | :
}
build() {
cd "${srcdir}/${_pkgname}/src/tunefish4/Builds/LinuxMakefile/"
+ export CPPFLAGS="$CPPFLAGS -I/usr/include/vst36"
make
}