summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authordan2014-09-02 00:26:42 +0000
committersvntogit2014-09-02 00:26:42 +0000
commit0995ca27639e98504abdd6a5c7a168188896af5b (patch)
tree73e11ef6416eb91c7d8294a7ac6be8e1d9687a4f
parent7fe10c407a8c9f64eee96cc9bff43062a96d66b2 (diff)
downloadaur-0995ca27639e98504abdd6a5c7a168188896af5b.tar.gz
upgpkg: django 1.6.6-1
git-svn-id: file:///srv/repos/svn-packages/svn@220880 eb2447ed-0c53-47e4-bac8-5bc4a241df78
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD21
2 files changed, 18 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index caf600320180..a76100b596d0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -2,7 +2,7 @@
# Wed Dec 30 18:02:57 UTC 2015
pkgbase = django
pkgdesc = A high-level Python Web framework that encourages rapid development and clean design
- pkgver = 1.6.5
+ pkgver = 1.6.6
pkgrel = 1
url = http://www.djangoproject.com/
arch = any
@@ -11,9 +11,9 @@ pkgbase = django
makedepends = python2-setuptools
makedepends = python
makedepends = python-setuptools
- source = https://www.djangoproject.com/m/releases/1.6/Django-1.6.5.tar.gz
- md5sums = e4c5b2d35ecb3807317713afa70a0c77
- sha256sums = 36940268c087fede32d3f5887cce9af9e5d27962a0c405aacafc2a3cc1f755c5
+ source = https://www.djangoproject.com/m/releases/1.6/Django-1.6.6.tar.gz
+ md5sums = d14fd332f31799fff39acc0c79e8421c
+ sha256sums = 536cbd54e533ba3563d205f0c91988b24e7d74b8b253d7825e42214b50ba7e90
pkgname = python-django
depends = python
diff --git a/PKGBUILD b/PKGBUILD
index 167a5771a712..8844e4bb3798 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgbase=django
pkgname=('python-django' 'python2-django')
-pkgver=1.6.5
+pkgver=1.6.6
pkgrel=1
pkgdesc="A high-level Python Web framework that encourages rapid development and clean design"
arch=('any')
@@ -12,11 +12,21 @@ license=('BSD')
url="http://www.djangoproject.com/"
makedepends=('python2' 'python2-setuptools' 'python' 'python-setuptools')
source=("https://www.djangoproject.com/m/releases/${pkgver:0:3}/Django-$pkgver.tar.gz")
-md5sums=('e4c5b2d35ecb3807317713afa70a0c77')
-sha256sums=('36940268c087fede32d3f5887cce9af9e5d27962a0c405aacafc2a3cc1f755c5')
+md5sums=('d14fd332f31799fff39acc0c79e8421c')
+sha256sums=('536cbd54e533ba3563d205f0c91988b24e7d74b8b253d7825e42214b50ba7e90')
+
+prepare() {
+ cp -a "$srcdir/Django-$pkgver" "$srcdir/Django-$pkgver-python2"
+
+ find "$srcdir/Django-$pkgver-python2" -name '*.py' | \
+ xargs sed -i "s|#!/usr/bin/env python$|#!/usr/bin/env python2|"
+}
build() {
cd "$srcdir/Django-$pkgver"
+ python setup.py build
+
+ cd "$srcdir/Django-$pkgver-python2"
python2 setup.py build
}
@@ -41,7 +51,7 @@ package_python2-django() {
'python2-psycopg2: for PostgreSQL backend')
replaces=('django')
conflicts=('django')
- cd "$srcdir/Django-$pkgver"
+ cd "$srcdir/Django-$pkgver-python2"
python2 setup.py install --root="$pkgdir" --optimize=1
ln -s django-admin.py "$pkgdir"/usr/bin/django-admin2.py
@@ -50,8 +60,5 @@ package_python2-django() {
ln -s django-admin.py \
"$pkgdir"/usr/share/bash-completion/completions/manage.py
- find "$pkgdir"/usr/lib/python2.7/site-packages/django/ -name '*.py' | \
- xargs sed -i "s|#!/usr/bin/env python$|#!/usr/bin/env python2|"
-
install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
}