summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGiovanni Harting2024-02-18 18:38:48 +0100
committerGiovanni Harting2024-02-18 18:38:48 +0100
commit09b3fa7ef3e98ea9adab4bf591d39b9c9abc26e3 (patch)
treee1f1dc07246ed264da04752a001c6d621a03600c
parentf848cfe1295b01f59244dd82adbe4aef09b2124c (diff)
downloadaur-09b3fa7ef3e98ea9adab4bf591d39b9c9abc26e3.tar.gz
upgpkg: nginx-mainline-mod-vts 0.2.2-1
reupload
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD52
2 files changed, 23 insertions, 36 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f58b56d1cc67..5c431f48c2aa 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -3,12 +3,11 @@ pkgbase = nginx-mainline-mod-vts
pkgver = 0.2.2
pkgrel = 1
url = https://github.com/vozlt/nginx-module-vts
- arch = i686
arch = x86_64
- license = BSD
+ license = BSD-2-Clause
makedepends = nginx-mainline-src
+ depends = nginx-mainline
source = nginx-module-vts-0.2.2.tar.gz::https://github.com/vozlt/nginx-module-vts/archive/v0.2.2.tar.gz
- sha256sums = 9353035331cfc5eec6c129eb8b348dab77f525329d4d60680a76e0c13c085f41
+ b2sums = 07c24eb62feeb145705ef07dc08feaa06b6b68f80b08e43ff8435bcd1ddbce2ce2d9adffd33efe635678eb787e39d9532f5fb0c22cedd2cb58445b2df14f96f5
pkgname = nginx-mainline-mod-vts
- depends = nginx-mainline
diff --git a/PKGBUILD b/PKGBUILD
index 7fcd0359777c..5344c7732227 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,45 +1,33 @@
-# Maintainer: Ivan Shapovalov <intelfx@intelfx.name>
-# Contributor: Massimiliano Torromeo <massimiliano.torromeo@gmail.com>
+# Maintainer: Giovanni Harting <539@idlegandalf.com>
pkgname=nginx-mainline-mod-vts
pkgver=0.2.2
pkgrel=1
-
-_modname="nginx-module-${pkgname#nginx-mainline-mod-}"
-
+_modname="nginx-module-vts"
pkgdesc='Nginx virtual host traffic status module (module for mainline nginx)'
-arch=('i686' 'x86_64')
-depends=() # the build process doesn't require or use installed nginx, so add the dependency in package() to break the cycle
-makedepends=('nginx-mainline-src')
+arch=(x86_64)
+depends=(nginx-mainline)
+makedepends=(nginx-mainline-src)
url="https://github.com/vozlt/nginx-module-vts"
-license=('BSD')
-
-source=(
- $_modname-$pkgver.tar.gz::https://github.com/vozlt/nginx-module-vts/archive/v$pkgver.tar.gz
-)
-
-sha256sums=('9353035331cfc5eec6c129eb8b348dab77f525329d4d60680a76e0c13c085f41')
-
-prepare() {
- mkdir -p build
- cd build
- ln -sf /usr/src/nginx/auto
- ln -sf /usr/src/nginx/src
-}
+license=(BSD-2-Clause)
+source=("$_modname-$pkgver.tar.gz::https://github.com/vozlt/nginx-module-vts/archive/v$pkgver.tar.gz")
+b2sums=('07c24eb62feeb145705ef07dc08feaa06b6b68f80b08e43ff8435bcd1ddbce2ce2d9adffd33efe635678eb787e39d9532f5fb0c22cedd2cb58445b2df14f96f5')
build() {
- cd build
- /usr/src/nginx/configure --with-compat --add-dynamic-module=../$_modname-$pkgver
- make modules
+ cp -r /usr/src/nginx .
+
+ cd nginx
+ ./configure --with-compat --add-dynamic-module=../$_modname-$pkgver
+ make modules
}
package() {
- depends=("nginx-mainline")
- install -Dm644 "$srcdir"/$_modname-$pkgver/LICENSE \
- "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+ install -Dm0644 "$_modname-$pkgver"/LICENSE "${pkgdir}"/usr/share/licenses/$pkgname/LICENSE
- cd build/objs
- for mod in *.so; do
- install -Dm755 $mod "$pkgdir"/usr/lib/nginx/modules/$mod
- done
+ cd nginx/objs
+ for mod in *.so; do
+ install -Dm755 $mod "$pkgdir"/usr/lib/nginx/modules/$mod
+ done
}
+
+# vim:set ts=2 sw=2 et: