summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFabioLolix2019-02-03 23:25:19 +0100
committerFabioLolix2019-02-03 23:25:19 +0100
commit09b924d0b8f417c1d1aaafbb62de449a47571b73 (patch)
tree76b5bd39d414ee4c69a049f514178cb00993b93f
downloadaur-09b924d0b8f417c1d1aaafbb62de449a47571b73.tar.gz
Initial commit
-rw-r--r--.SRCINFO38
-rw-r--r--PKGBUILD49
2 files changed, 87 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f5727ead53cc
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,38 @@
+pkgbase = inxi-perl-git
+ pkgdesc = Pinxi, development branch of inxi, a full featured CLI system information tool
+ pkgver = r2755.00283844
+ pkgrel = 1
+ url = https://github.com/smxi/inxi
+ arch = any
+ license = GPL3
+ makedepends = git
+ depends = coreutils
+ depends = pciutils
+ depends = perl
+ depends = procps-ng
+ optdepends = bind-tools: -i wlan IP
+ optdepends = dmidecode: inxi -M if no sys machine data
+ optdepends = file: inxi -o unmounted file system
+ optdepends = hddtemp: inxi -Dx show hdd temp
+ optdepends = iproute2: inxi -i ip lan
+ optdepends = kmod: inxi -Ax,-Nx module version
+ optdepends = lm_sensors: inxi -s sensors output
+ optdepends = mesa-demos: inxi -G glx info
+ optdepends = net-tools: inxi -i ip lan-deprecated
+ optdepends = perl-io-socket-ssl: -U; -w,-W; -i (if dig not installed)
+ optdepends = perl-cpanel-json-xs: --output json - required for export
+ optdepends = perl-json-xs: --output json - required for export (legacy)
+ optdepends = perl-xml-dumper: --output xml - Crude and raw
+ optdepends = systemd-sysvcompat: inxi -I runlevel
+ optdepends = sudo: inxi -Dx hddtemp-user;-o file-user
+ optdepends = tree: --debugger 20,21 /sys tree
+ optdepends = usbutils: inxi -A usb audio;-N usb networking
+ optdepends = wmctrl: -S active window manager (not all wm)
+ optdepends = xorg-xdpyinfo: inxi -G multi screen resolution
+ optdepends = xorg-xprop: inxi -S desktop data
+ optdepends = xorg-xrandr: inxi -G single screen resolution
+ source = git+https://github.com/smxi/inxi.git#branch=inxi-perl
+ sha256sums = SKIP
+
+pkgname = inxi-perl-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c23dee276ff8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,49 @@
+# Maintainer: Fabio 'Lolix' Loli <lolix@disroot.org> -> https://github.com/FabioLolix
+# Contributor: FadeMind <fademind@gmail.com>
+
+pkgname=inxi-perl-git
+pkgver=r2755.00283844
+pkgrel=1
+pkgdesc="Pinxi, development branch of inxi, a full featured CLI system information tool"
+arch=(any)
+url="https://github.com/smxi/inxi"
+license=(GPL3)
+depends=(coreutils pciutils perl procps-ng)
+makedepends=(git)
+optdepends=(
+ "bind-tools: -i wlan IP"
+ "dmidecode: inxi -M if no sys machine data"
+ "file: inxi -o unmounted file system"
+ "hddtemp: inxi -Dx show hdd temp"
+ "iproute2: inxi -i ip lan"
+ "kmod: inxi -Ax,-Nx module version"
+ "lm_sensors: inxi -s sensors output"
+ "mesa-demos: inxi -G glx info"
+ "net-tools: inxi -i ip lan-deprecated"
+ "perl-io-socket-ssl: -U; -w,-W; -i (if dig not installed)"
+ "perl-cpanel-json-xs: --output json - required for export"
+ "perl-json-xs: --output json - required for export (legacy)"
+ "perl-xml-dumper: --output xml - Crude and raw"
+ "systemd-sysvcompat: inxi -I runlevel"
+ "sudo: inxi -Dx hddtemp-user;-o file-user"
+ "tree: --debugger 20,21 /sys tree"
+ "usbutils: inxi -A usb audio;-N usb networking"
+ "wmctrl: -S active window manager (not all wm)"
+ "xorg-xdpyinfo: inxi -G multi screen resolution"
+ "xorg-xprop: inxi -S desktop data"
+ "xorg-xrandr: inxi -G single screen resolution"
+)
+source=("git+https://github.com/smxi/inxi.git#branch=inxi-perl")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/${pkgname/-perl-git/}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "$srcdir/${pkgname/-perl-git/}"
+ install -D -m755 pinxi "$pkgdir/usr/bin/pinxi"
+ install -D -m755 pinxi.1 "$pkgdir/usr/share/man/man1/pinxi.1.gz"
+}
+